summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHu3rror2022-10-19 18:18:48 +0800
committerHu3rror2022-10-19 18:18:48 +0800
commitc69474a92419e0673d37d8ba9538343a3e227295 (patch)
treed572306257761b121e1badbfbc495536f2bc173a
downloadaur-c69474a92419e0673d37d8ba9538343a3e227295.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e9ac28d0e02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = animationgarden-bin
+ pkgdesc = Desktop application for Animation Garden.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/Him188/animation-garden-desktop
+ arch = x86_64
+ license = GPL
+ depends = expat
+ depends = util-linux-libs
+ depends = xdg-utils
+ depends = zlib
+ source = https://github.com/Him188/animation-garden-desktop/releases/download/v1.2.0/AnimationGarden-1.2.0-debian-amd64.deb
+ sha512sums = caa045b570ca143d1b5e1c28293f6c18464e7e84353d2f814d361478588c93535f6a7ff267b01b5572e79cac5f0251bf0f26d65f62abd4ef0456f228bb120d1a
+
+pkgname = animationgarden-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ae491e5446d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hu3rror <hu3rror@protonmail.com>
+
+pkgname=animationgarden-bin
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Desktop application for Animation Garden."
+arch=('x86_64')
+url="https://github.com/Him188/animation-garden-desktop"
+license=('GPL')
+depends=('expat' 'util-linux-libs' 'xdg-utils' 'zlib')
+source=("https://github.com/Him188/animation-garden-desktop/releases/download/v1.2.0/AnimationGarden-1.2.0-debian-amd64.deb")
+sha512sums=('caa045b570ca143d1b5e1c28293f6c18464e7e84353d2f814d361478588c93535f6a7ff267b01b5572e79cac5f0251bf0f26d65f62abd4ef0456f228bb120d1a')
+
+package(){
+ cd "${srcdir}"
+ # Extract package dataj
+ tar -xJ -f data.tar.xz -C "${pkgdir}"
+ install -dm755 "${pkgdir}"/usr/bin
+ ln -s /opt/animationgarden/bin/AnimationGarden "${pkgdir}"/usr/bin/AnimationGarden
+ install -Dm644 "${pkgdir}"/opt/animationgarden/share/doc/copyright "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
+ sed -i 's|^Exec=/opt/animationgarden/bin/AnimationGarden|Exec=AnimationGarden|g' "$pkgdir"/opt/animationgarden/lib/animationgarden-AnimationGarden.desktop
+ install -Dm644 "${pkgdir}/opt/animationgarden/lib/AnimationGarden.png" "${pkgdir}/usr/share/pixmaps/AnimationGarden.png"
+}