summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-08 09:26:13 +0800
committerzxp198210052024-04-08 09:26:13 +0800
commit8258fd7f1195639eb0c84ceef8e8e8802c214bc0 (patch)
tree5a97be364759c568d0df66a3ea36d6b8c512d402
parent37fcd5829eef33968df46895f269bc04d322abc6 (diff)
downloadaur-8258fd7f1195639eb0c84ceef8e8e8802c214bc0.tar.gz
update to 2.0.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 8 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d82c7f40765..8042cdab1353 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = animeclient-bin
pkgdesc = An application that brings together several anime streaming platforms
- pkgver = 2.0.3
+ pkgver = 2.0.4
pkgrel = 1
url = https://zvbt.github.io/AnimeClient/
arch = x86_64
license = MIT
makedepends = fuse2
- makedepends = asar
- makedepends = npm
depends = electron28
- provides = animeclient=2.0.3
+ provides = animeclient=2.0.4
conflicts = animeclient
- source = animeclient-2.0.3.AppImage::https://github.com/zvbt/AnimeClient/releases/download/v2.0.3/AnimeClient-2.0.3.AppImage
- source = LICENSE-2.0.3::https://raw.githubusercontent.com/zvbt/AnimeClient/v2.0.3/LICENSE
+ source = animeclient-2.0.4.AppImage::https://github.com/zvbt/AnimeClient/releases/download/v2.0.4/AnimeClient-2.0.4.AppImage
+ source = LICENSE-2.0.4::https://raw.githubusercontent.com/zvbt/AnimeClient/v2.0.4/LICENSE
source = animeclient.sh
- sha256sums = 0aca58db2d565ccdb42e493068d19068a551681fa3b6863b59ac17d489a14e07
+ sha256sums = ad2f3a41e497cd2755be9825e7a653d8100b1d0d70162069e0c93d425a0795a5
sha256sums = ffc59750487e679e55e98c059d8d61c3c5f11eab0d297c34581db22c07cdf27d
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
diff --git a/PKGBUILD b/PKGBUILD
index 948503e38b88..4279e8adbdc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=animeclient-bin
_pkgname=AnimeClient
-pkgver=2.0.3
+pkgver=2.0.4
_electronversion=28
pkgrel=1
pkgdesc="An application that brings together several anime streaming platforms"
@@ -16,15 +16,13 @@ depends=(
)
makedepends=(
'fuse2'
- 'asar'
- 'npm'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage"
"LICENSE-${pkgver}::https://raw.githubusercontent.com/zvbt/AnimeClient/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('0aca58db2d565ccdb42e493068d19068a551681fa3b6863b59ac17d489a14e07'
+sha256sums=('ad2f3a41e497cd2755be9825e7a653d8100b1d0d70162069e0c93d425a0795a5'
'ffc59750487e679e55e98c059d8d61c3c5f11eab0d297c34581db22c07cdf27d'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
@@ -36,22 +34,10 @@ build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
- asar e "${srcdir}/squashfs-root/resources/app.asar" "${srcdir}/app.asar.unpacked"
- if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- export npm_config_registry=https://registry.npmmirror.com
- export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
- export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
- else
- echo "Your network is OK."
- fi
- cd "${srcdir}/app.asar.unpacked"
- npm add discord-rpc
- sed "s|logo.ico|logo.png|g" -i index.js
- asar p "${srcdir}/app.asar.unpacked" "${srcdir}/app.asar"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/"{app.asar,engine.bin} -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"