summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Barberee2016-07-19 11:12:05 -0500
committerSeth Barberee2016-07-19 11:12:05 -0500
commit0c69d45b63ec9f297584da962c5b160cf81f9516 (patch)
treed6cffe6848e365b2d669966e4b6f98029ec38aa2
downloadaur-0c69d45b63ec9f297584da962c5b160cf81f9516.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38149749b43f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = animewatch-pyqt5
+ pkgdesc = An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection based on PyQt5-WebEngine
+ pkgver = 3.0.0.r12.0840967
+ pkgrel = 1
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = qt5-webengine
+ depends = python-pyqt5
+ depends = python-pycurl
+ depends = python-urllib3
+ depends = curl
+ depends = libnotify
+ depends = python-dbus
+ depends = python-beautifulsoup4
+ depends = python-psutil
+ depends = python-pillow
+ depends = python-lxml
+ depends = mpv
+ depends = mplayer
+ depends = ffmpegthumbnailer
+ depends = sqlite3
+ depends = python-pytaglib
+ conflicts = animewatch-pyqt4
+ source = git+https://github.com/kanishka-linux/AnimeWatch.git
+ md5sums = SKIP
+
+pkgname = animewatch-pyqt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2686577b96a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=animewatch-pyqt5
+_pkgname=AnimeWatch
+pkgver=3.0.0.r12.0840967
+pkgrel=1
+pkgdesc="An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection based on PyQt5-WebEngine"
+arch=(any)
+conflicts=('animewatch-pyqt4')
+license=('GPL3')
+depends=('python' 'qt5-webengine' 'python-pyqt5' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus'
+ 'python-beautifulsoup4' 'python-psutil' 'python-pillow' 'python-lxml' 'mpv' 'mplayer' 'ffmpegthumbnailer' 'sqlite3' 'python-pytaglib')
+
+makedepends=('git')
+
+source=("git+https://github.com/kanishka-linux/AnimeWatch.git")
+#source=("https://github.com/kanishka-linux/"${pkgname}"/archive/v"${pkgver}-${pkgrel}".zip")
+md5sums=('SKIP')
+_gitname=AnimeWatch-PyQt5-WebEngine-Stable
+
+
+package() {
+
+ _bpath="${srcdir}/AnimeWatch/${_gitname}"
+
+ install -d "${pkgdir}/usr/share/${_pkgname}/"
+ install -d "${pkgdir}/usr/share/${_pkgname}/Plugins/"
+ install -d "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/bin/"
+
+ install -Dm755 "${_bpath}"/{animeWatch.py,musicArtist.py,adb.py,1.png,input.conf,default.jpg,default.html,introspect.xml,stream.png} "${pkgdir}/usr/share/${_pkgname}/"
+ cat "${_bpath}/AnimeWatch.desktop" | sed 's/Exec=/Exec=python -B \/usr\/share\/AnimeWatch\/animeWatch.py \%u/g' > "${pkgdir}/usr/share/applications/AnimeWatch.desktop"
+ echo '#!/bin/bash' > "${pkgdir}/usr/bin/anime-watch"
+ echo 'if [ -z "$1" ]; then python -B /usr/share/AnimeWatch/animeWatch.py; else python -B /usr/share/AnimeWatch/animeWatch.py "$(pwd)/$1"; fi' >> "${pkgdir}/usr/bin/anime-watch"
+ chmod +x "${pkgdir}/usr/bin/anime-watch"
+
+ for file in "${_bpath}/Plugins/"*;do
+ nm=$(echo $file | rev | cut -d'/' -f1 | rev)
+ if [ $nm != "installPlugins.py" ];then
+ #echo $nm
+ install -Dm755 "$file" "${pkgdir}/usr/share/${_pkgname}/Plugins/"
+ fi
+ done
+}