summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Barberee2016-08-12 17:22:48 -0500
committerSeth Barberee2016-08-12 17:22:48 -0500
commit0ec41118a41c8e9b4321cdd6424920db1fe9cd37 (patch)
tree1e4574e8fbef8e7c8ce482672c621964779693cb
parent5cfb2260d435835d5328a7392b866cf884d18e5e (diff)
downloadaur-0ec41118a41c8e9b4321cdd6424920db1fe9cd37.tar.gz
updated PKGBUILD with new dep according to source
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 847e474ab612..59fd0222896e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = animewatch-pyqt5
pkgdesc = An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection based on PyQt5-WebEngine
- pkgver = 3.0.0.r14.7bc9fd9
+ pkgver = 3.0.0.r15.9ed2ca3
pkgrel = 1
url = https://github.com/kanishka-linux/AnimeWatch
arch = any
@@ -14,6 +14,7 @@ pkgbase = animewatch-pyqt5
depends = curl
depends = libnotify
depends = python-dbus
+ depends = libtorrent-rasterbar
depends = python-beautifulsoup4
depends = python-psutil
depends = python-pillow
diff --git a/PKGBUILD b/PKGBUILD
index 59550ed7bd2a..00f2cbe23a35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=animewatch-pyqt5
_pkgname=AnimeWatch
-pkgver=3.0.0.r14.7bc9fd9
+pkgver=3.0.0.r15.9ed2ca3
pkgrel=1
pkgdesc="An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection based on PyQt5-WebEngine"
arch=(any)
conflicts=('animewatch-pyqt4')
url="https://github.com/kanishka-linux/AnimeWatch"
license=('GPL3')
-depends=('python' 'qt5-webengine' 'python-pyqt5' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus'
+depends=('python' 'qt5-webengine' 'python-pyqt5' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus' 'libtorrent-rasterbar'
'python-beautifulsoup4' 'python-psutil' 'python-pillow' 'python-lxml' 'mpv' 'mplayer' 'ffmpegthumbnailer' 'sqlite3' 'python-pytaglib')
makedepends=('git')
@@ -29,7 +29,7 @@ package() {
install -d "${pkgdir}/usr/share/applications/"
install -d "${pkgdir}/usr/bin/"
- install -Dm755 "${_bpath}"/{animeWatch.py,musicArtist.py,adb.py,1.png,input.conf,default.jpg,default.html,introspect.xml,stream.png} "${pkgdir}/usr/share/${_pkgname}/"
+ install -Dm755 "${_bpath}"/{animeWatch.py,musicArtist.py,adb.py,1.png,input.conf,default.jpg,introspect.xml,stream.py,tray.png} "${pkgdir}/usr/share/${_pkgname}/"
cat "${_bpath}/AnimeWatch.desktop" | sed 's/Exec=/Exec=python -B \/usr\/share\/AnimeWatch\/animeWatch.py \%u/g' > "${pkgdir}/usr/share/applications/AnimeWatch.desktop"
echo '#!/bin/bash' > "${pkgdir}/usr/bin/anime-watch"
echo 'if [ -z "$1" ]; then python -B /usr/share/AnimeWatch/animeWatch.py; else python -B /usr/share/AnimeWatch/animeWatch.py "$(pwd)/$1"; fi' >> "${pkgdir}/usr/bin/anime-watch"