summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Barberee2016-09-25 06:31:21 -0500
committerSeth Barberee2016-09-25 06:31:21 -0500
commitc6d9ecb8b343ce3fa3d3f12c9ac742466e062f3e (patch)
treee5d09c714a49f048034bb407ab74b0a0604e6bfd
downloadaur-c6d9ecb8b343ce3fa3d3f12c9ac742466e062f3e.tar.gz
created git package for pyqt5
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD64
2 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50e6d39c5669
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = animewatch-pyqt5.git
+ pkgdesc = An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection
+ pkgver = 3.0.0.r31.fffb7b9
+ pkgrel = 1
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = qt5-webengine
+ depends = python-pyqt5
+ depends = python-pycurl
+ depends = python-urllib3
+ depends = curl
+ depends = libnotify
+ depends = python-dbus
+ depends = libtorrent-rasterbar
+ depends = python-beautifulsoup4
+ depends = python-psutil
+ depends = python-pillow
+ depends = python-lxml
+ depends = mpv
+ depends = mplayer
+ depends = ffmpegthumbnailer
+ depends = sqlite3
+ depends = python-pytaglib
+ depends = livestreamer
+ depends = youtube-dl
+ depends = wget
+ conflicts = animewatch-pyqt4
+ conflicts = animewatch-pyqt5
+ source = git+https://github.com/kanishka-linux/AnimeWatch.git
+ md5sums = SKIP
+
+pkgname = animewatch-pyqt5.git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1cae1155040
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+pkgname=animewatch-pyqt5.git
+_pkgname=AnimeWatch
+pkgver=3.0.0.r31.fffb7b9
+pkgrel=1
+pkgdesc="An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection"
+arch=(any)
+conflicts=('animewatch-pyqt4' 'animewatch-pyqt5')
+license=('GPL3')
+depends=('python' 'qt5-webengine' 'python-pyqt5' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus' 'libtorrent-rasterbar'
+ 'python-beautifulsoup4' 'python-psutil' 'python-pillow' 'python-lxml' 'mpv' 'mplayer' 'ffmpegthumbnailer' 'sqlite3' 'python-pytaglib'
+ 'livestreamer' 'youtube-dl' 'wget')
+#optdepends=('livestreamer' 'youtube-dl' 'wget')
+makedepends=('git')
+
+source=("git+https://github.com/kanishka-linux/AnimeWatch.git")
+#source=("https://github.com/kanishka-linux/"${pkgname}"/archive/v"${pkgver}-${pkgrel}".zip")
+md5sums=('SKIP')
+_gitname=AnimeWatch-PyQt5
+
+
+package() {
+
+ _bpath="${srcdir}/AnimeWatch/${_gitname}"
+
+ install -d "${pkgdir}/usr/share/${_pkgname}/"
+ install -d "${pkgdir}/usr/share/${_pkgname}/Plugins/"
+ install -d "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/bin/"
+
+ for file in "${_bpath}/"*;do
+ nm=$(echo $file | rev | cut -d'/' -f1 | rev)
+ if [ -d "$file" ];then
+ if [ $nm == 'Plugins' ];then
+ _plugin_path="$file/"
+ for plugins in "${_plugin_path}"*;do
+ plugin_name=$(echo $plugins | rev | cut -d'/' -f1 | rev)
+ if [ plugin_name != 'installPlugins.py' ];then
+ echo $plugins
+ echo 'Plugins copying'
+ install -Dm755 "$plugins" "${pkgdir}/usr/share/${_pkgname}/Plugins/"
+ fi
+ done
+ fi
+ else
+ if [ $nm == 'AnimeWatch.desktop' ];then
+ echo $file
+ echo 'desktop file copying'
+ cat "$file" | sed 's/Exec=/Exec=python -B \/usr\/share\/AnimeWatch\/animeWatch.py \%u/g' > "${pkgdir}/usr/share/applications/AnimeWatch.desktop"
+ elif [ $nm == 'anime-watch' ];then
+ echo $file
+ echo 'anime-watch script'
+ install -Dm755 "$file" "${pkgdir}/usr/bin/anime-watch"
+ chmod +x "${pkgdir}/usr/bin/anime-watch"
+ else
+ if [ $nm != 'install.py' ];then
+ echo $file
+ echo 'source files copying'
+ install -Dm755 "$file" "${pkgdir}/usr/share/${_pkgname}/"
+ fi
+ fi
+ fi
+ done
+
+}