summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-13 16:05:17 +0800
committerzxp198210052024-03-13 16:05:17 +0800
commit0469124129603da3dfacb126ba2f2218794275ab (patch)
treed5cf82e549326a91d2b77864bb57753d6850ed15
parentcd75fc2b28c349e5e0fb54e0ce81d22a338eb758 (diff)
downloadaur-0469124129603da3dfacb126ba2f2218794275ab.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--aniship.sh8
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdcbefdacdf7..feea71a6841e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = aniship-bin
pkgdesc = A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops.
pkgver = 0.0.4.2
- pkgrel = 6
+ pkgrel = 7
url = https://t.me/aniship
arch = x86_64
license = MIT
- depends = electron16
+ makedepends = fuse2
+ depends = electron16-bin
provides = aniship=0.0.4.2
conflicts = aniship
source = aniship-0.0.4.2.AppImage::https://github.com/progzone122/AniShip/releases/download/v0.0.4.2night/setup-0.0.4-2.AppImage
source = aniship.sh
sha256sums = 1fbe0e6388982d71268c4f4f04bf7c3f82ac0a6dee8310f8599d93be565525d2
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = aniship-bin
diff --git a/PKGBUILD b/PKGBUILD
index 465fed3611f0..bb499f00a0b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=aniship-bin
pkgver=0.0.4.2
_electronversion=16
-pkgrel=6
+pkgrel=7
pkgdesc="A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops."
arch=('x86_64')
url="https://t.me/aniship"
@@ -11,18 +11,22 @@ license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
+)
+makedepends=(
+ 'fuse2'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}night/setup-${pkgver//.2/-2}.AppImage"
"${pkgname%-bin}.sh"
)
sha256sums=('1fbe0e6388982d71268c4f4f04bf7c3f82ac0a6dee8310f8599d93be565525d2'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/aniship.sh b/aniship.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/aniship.sh
+++ b/aniship.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file