summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-02 10:52:50 +0800
committerzxp198210052023-08-02 10:52:50 +0800
commit21e45c28b5e0b43d5c60a6bdbf192a22fa738f3e (patch)
tree59594bce84d10402d53e43d9fc85847e302329ad
parent9f2af55fef842b32bcbf3cb992655ce957035b06 (diff)
downloadaur-21e45c28b5e0b43d5c60a6bdbf192a22fa738f3e.tar.gz
optimized PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--aniship.sh6
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e73ef99e148..41f1653ed1a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = aniship-bin
pkgdesc = A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops.
- pkgver = 0.0.4
+ pkgver = 0.0.4.2
pkgrel = 1
url = https://t.me/aniship
arch = x86_64
license = custom
- depends = electron
+ depends = bash
+ depends = electron16
depends = gcc-libs
depends = glibc
+ provides = aniship
conflicts = aniship
- source = aniship-0.0.4.AppImage::https://github.com/progzone122/AniShip/releases/download/v0.0.4-night/setup-0.0.4.AppImage
+ source = aniship-0.0.4.2.AppImage::https://github.com/progzone122/AniShip/releases/download/v0.0.4.2night/setup-0.0.4-2.AppImage
source = aniship.sh
- sha256sums = 344a3c493d52a33a1cc522e401f760fce653357ac3dc726b458739d6b1038f2b
- sha256sums = dda7e4f0b91ac9ee3b9aa5d72f985899234684e7973442ce9cdc4905da16b72e
+ sha256sums = 1fbe0e6388982d71268c4f4f04bf7c3f82ac0a6dee8310f8599d93be565525d2
+ sha256sums = 5fb5356053631c4ac7ad2ab51f0f4738569d918b9c4407f7db64ba05d7be8896
pkgname = aniship-bin
diff --git a/PKGBUILD b/PKGBUILD
index 758a8176625a..d1de3f311eff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="aniship-bin"
-pkgver=0.0.4
+pkgver=0.0.4.2
pkgrel=1
pkgdesc="A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops."
arch=('x86_64')
url="https://t.me/aniship"
_githuburl="https://github.com/progzone122/AniShip"
license=('custom')
+provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-depends=('electron' 'gcc-libs' 'glibc')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}-night/setup-${pkgver}.AppImage"
+depends=('bash' 'electron16' 'gcc-libs' 'glibc')
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}night/setup-0.0.4-2.AppImage"
"${pkgname%-bin}.sh")
-sha256sums=('344a3c493d52a33a1cc522e401f760fce653357ac3dc726b458739d6b1038f2b'
- 'dda7e4f0b91ac9ee3b9aa5d72f985899234684e7973442ce9cdc4905da16b72e')
+sha256sums=('1fbe0e6388982d71268c4f4f04bf7c3f82ac0a6dee8310f8599d93be565525d2'
+ '5fb5356053631c4ac7ad2ab51f0f4738569d918b9c4407f7db64ba05d7be8896')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/aniship.sh b/aniship.sh
index 260dc8d9be48..0e683cbb3d76 100644
--- a/aniship.sh
+++ b/aniship.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron16
+_ASAR="/opt/aniship/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron /opt/aniship/app.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron --no-sandbox /opt/aniship/app.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file