summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-06 18:19:50 +0800
committerzxp198210052023-07-06 18:19:50 +0800
commit9f2af55fef842b32bcbf3cb992655ce957035b06 (patch)
tree31cf88eb951cc10406e9ba9bf4149bfd6bf7efc1
downloadaur-9f2af55fef842b32bcbf3cb992655ce957035b06.tar.gz
first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--aniship.sh6
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e73ef99e148
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aniship-bin
+ pkgdesc = A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops.
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://t.me/aniship
+ arch = x86_64
+ license = custom
+ depends = electron
+ depends = gcc-libs
+ depends = glibc
+ conflicts = aniship
+ source = aniship-0.0.4.AppImage::https://github.com/progzone122/AniShip/releases/download/v0.0.4-night/setup-0.0.4.AppImage
+ source = aniship.sh
+ sha256sums = 344a3c493d52a33a1cc522e401f760fce653357ac3dc726b458739d6b1038f2b
+ sha256sums = dda7e4f0b91ac9ee3b9aa5d72f985899234684e7973442ce9cdc4905da16b72e
+
+pkgname = aniship-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..758a8176625a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="aniship-bin"
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops."
+arch=('x86_64')
+url="https://t.me/aniship"
+_githuburl="https://github.com/progzone122/AniShip"
+license=('custom')
+conflicts=("${pkgname%-bin}")
+depends=('electron' 'gcc-libs' 'glibc')
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}-night/setup-${pkgver}.AppImage"
+ "${pkgname%-bin}.sh")
+sha256sums=('344a3c493d52a33a1cc522e401f760fce653357ac3dc726b458739d6b1038f2b'
+ 'dda7e4f0b91ac9ee3b9aa5d72f985899234684e7973442ce9cdc4905da16b72e')
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} \;
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}-night.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g;s|Icon=${pkgname%-bin}-night|Icon=${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}-night.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}-night.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/aniship.sh b/aniship.sh
new file mode 100644
index 000000000000..260dc8d9be48
--- /dev/null
+++ b/aniship.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron /opt/aniship/app.asar "$@"
+else
+ exec electron --no-sandbox /opt/aniship/app.asar "$@"
+fi \ No newline at end of file