summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-22 08:28:31 +0800
committerzxp198210052024-02-22 08:28:31 +0800
commitcd75fc2b28c349e5e0fb54e0ce81d22a338eb758 (patch)
tree1bb71d81eaf051f78a26f6864dcbb58ddaa86172
parent43dfcb9d4884a4318ff9950bb8a3343d204841e8 (diff)
downloadaur-cd75fc2b28c349e5e0fb54e0ce81d22a338eb758.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--aniship.sh9
3 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fa288f8b539..fdcbefdacdf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = aniship-bin
pkgdesc = A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops.
pkgver = 0.0.4.2
- pkgrel = 5
+ pkgrel = 6
url = https://t.me/aniship
arch = x86_64
- license = custom
- makedepends = squashfuse
+ license = MIT
depends = electron16
provides = aniship=0.0.4.2
conflicts = aniship
source = aniship-0.0.4.2.AppImage::https://github.com/progzone122/AniShip/releases/download/v0.0.4.2night/setup-0.0.4-2.AppImage
source = aniship.sh
sha256sums = 1fbe0e6388982d71268c4f4f04bf7c3f82ac0a6dee8310f8599d93be565525d2
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = aniship-bin
diff --git a/PKGBUILD b/PKGBUILD
index 58e2c1152142..465fed3611f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,27 @@
pkgname=aniship-bin
pkgver=0.0.4.2
_electronversion=16
-pkgrel=5
+pkgrel=6
pkgdesc="A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops."
arch=('x86_64')
url="https://t.me/aniship"
_ghurl="https://github.com/progzone122/AniShip"
-license=('custom')
+license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
)
-makedepends=(
- 'squashfuse'
-)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}night/setup-${pkgver//.2/-2}.AppImage"
"${pkgname%-bin}.sh"
)
sha256sums=('1fbe0e6388982d71268c4f4f04bf7c3f82ac0a6dee8310f8599d93be565525d2'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/aniship.sh b/aniship.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/aniship.sh
+++ b/aniship.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file