summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2017-04-05 20:50:40 -0400
committerYaohan Chen2017-04-05 20:50:40 -0400
commit4a9dbc1a41a2a967d1fd2e523cfb3bb75e375682 (patch)
treeec7e4eb31f78441af5841afc010fb196dcbf8c50
parenta5e035835084d83facb33943e412797f0dbb9d44 (diff)
downloadaur-4a9dbc1a41a2a967d1fd2e523cfb3bb75e375682.tar.gz
Fix PulseAudio sound issue
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--transition.sh12
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25b0ae5dcb3..c7ba51e37d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Apr 2 01:44:47 UTC 2017
+# Thu Apr 6 00:50:09 UTC 2017
pkgbase = ankama-transition
pkgdesc = Updater for Ankama games Dofus and Wakfu
pkgver = 3.11.1
- pkgrel = 1
+ pkgrel = 3
url = http://www.ankama.com
install = ankama-transition.install
arch = i686
@@ -15,7 +15,7 @@ pkgbase = ankama-transition
source = http://dl.ak.ankama.com/games/linux/ankama-transition-release.tar.gz
source = transition.sh
md5sums = bac15a49942ac46c8270e8f5b94c3d1c
- md5sums = 2be6feebbe106c854ca79d623a030d70
+ md5sums = cedd4443adb36d718f46962023e327b4
pkgname = ankama-transition
diff --git a/PKGBUILD b/PKGBUILD
index c641557a073..66d4a461d32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=ankama-transition
pkgver=3.11.1
-pkgrel=2
+pkgrel=3
pkgdesc="Updater for Ankama games Dofus and Wakfu"
arch=('i686' 'x86_64')
url="http://www.ankama.com"
@@ -10,7 +10,7 @@ depends=('qt4' 'polkit' 'openssl')
source=('http://dl.ak.ankama.com/games/linux/ankama-transition-release.tar.gz'
'transition.sh')
md5sums=('bac15a49942ac46c8270e8f5b94c3d1c'
- 'b54e01b3d6138ceffa57f976eff25e52')
+ 'cedd4443adb36d718f46962023e327b4')
install='ankama-transition.install'
prepare() {
diff --git a/transition.sh b/transition.sh
index 88397123a0b..13e38aeafdf 100644
--- a/transition.sh
+++ b/transition.sh
@@ -3,4 +3,14 @@
unset SESSION_MANAGER
# If default openssl is 1.1.1, the updater will crash
-LD_RUN_PATH=/usr/lib/openssl-1.0 /opt/ankama/transition/transition "$@"
+export LD_RUN_PATH=/usr/lib/openssl-1.0
+
+transition=/opt/ankama/transition/transition
+
+# If in PulseAudio, need padsp for the game to play sounds
+if which padsp > /dev/null
+then
+ padsp "$transition" "$@"
+else
+ "$transition" "$@"
+fi