summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-02-22 12:51:21 +0100
committerAlexBocken2023-02-22 12:51:21 +0100
commitc38254b077cf4fb7cf8ff08aef914ee7477a41cc (patch)
treed15eafcc3673b7247830f1d9b882e22990aa69e1
parent181e427dfdf50158c5c9b03afe35c87510e52f6b (diff)
downloadaur-c38254b077cf4fb7cf8ff08aef914ee7477a41cc.tar.gz
bump to 2.1.60, moved to "anki" srcdir to reduce space needed for updates
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d619f7fc91cd..8be687d01b82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anki
pkgdesc = Helps you remember facts (like words/phrases in a foreign language) efficiently
- pkgver = 2.1.58
+ pkgver = 2.1.60
pkgrel = 1
url = https://apps.ankiweb.net/
arch = x86_64
@@ -37,7 +37,7 @@ pkgbase = anki
conflicts = anki-official-binary-bundle
conflicts = anki-qt5
options = !lto
- source = anki-2.1.58::git+https://github.com/ankitects/anki#tag=2.1.58
+ source = anki::git+https://github.com/ankitects/anki#tag=2.1.60
source = no-update.patch
sha256sums = SKIP
sha256sums = 137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797
diff --git a/PKGBUILD b/PKGBUILD
index bcf65cb35870..d465a54ab833 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Dave Pretty <david dot pretty at gmail dot com>
pkgname=anki
-pkgver=2.1.58
+pkgver=2.1.60
pkgrel=1
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) efficiently"
url="https://apps.ankiweb.net/"
@@ -55,7 +55,7 @@ optdepends=(
)
# using the tag tarballs does not work with the new (>= 2.1.55) build process.
# the '.git' folder is not included in those but is required for a sucessful build
-source=("anki-${pkgver}::git+https://github.com/ankitects/anki#tag=${pkgver}"
+source=("anki::git+https://github.com/ankitects/anki#tag=${pkgver}"
"no-update.patch"
)
sha256sums=('SKIP'
@@ -63,19 +63,19 @@ sha256sums=('SKIP'
)
prepare(){
- cd "anki-$pkgver"
+ cd "anki"
# pro-actively prevent "module not found" error (TODO: verify whether still required)
[ -d ts/node_modules ] && rm -r ts/node_modules
patch -p1 < "$srcdir/no-update.patch"
}
build() {
- cd "anki-$pkgver"
+ cd "anki"
./tools/build
}
package() {
- cd "anki-$pkgver"
+ cd "anki"
for file in out/wheels/*.whl; do
python -m installer --destdir="$pkgdir" $file
done