summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrafcube2022-04-09 16:11:41 +0530
committerGrafcube2022-04-09 16:12:32 +0530
commit2ca15212892c75e1f94fda5bd328bc4b5ee7156d (patch)
treed76d4471b8a9da2823f10a3adc81c230a56fef3c
parentb24d7224c202b49b27240cf764cad9f3e8cb1d67 (diff)
downloadaur-2ca15212892c75e1f94fda5bd328bc4b5ee7156d.tar.gz
Upgrade to 2.1.50 with PyQT6
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD19
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dce79efd380..881d9ad6afcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anki-bin
pkgdesc = Helps you remember facts (like words/phrases in a foreign language) efficiently. Installed with wheel.
- pkgver = 2.1.49
+ pkgver = 2.1.50
pkgrel = 1
url = https://apps.ankiweb.net/
arch = x86_64
@@ -15,6 +15,7 @@ pkgbase = anki-bin
depends = python-pyqtwebengine
depends = python-send2trash
depends = python-waitress
+ depends = python-pyqt6-webengine
depends = python-decorator
depends = python-distro
depends = python-markdown
@@ -25,22 +26,22 @@ pkgbase = anki-bin
optdepends = lame: record sound
optdepends = mpv: play sound. prefered over mplayer
optdepends = mplayer: play sound
- provides = anki=2.1.49
+ provides = anki=2.1.50
conflicts = anki
- noextract = anki-2.1.49-cp38-abi3-manylinux2014_x86_64.whl
- noextract = aqt-2.1.49-py3-none-any.whl
+ noextract = anki-2.1.50-cp39-abi3-manylinux_2_28_x86_64.whl
+ noextract = aqt-2.1.50-py3-none-any.whl
noextract = runanki.py
noextract = anki.desktop
noextract = anki.png
- source = https://files.pythonhosted.org/packages/cp38/a/anki/anki-2.1.49-cp38-abi3-manylinux2014_x86_64.whl
- source = https://files.pythonhosted.org/packages/py3/a/aqt/aqt-2.1.49-py3-none-any.whl
- source = https://raw.githubusercontent.com/ankitects/anki/2.1.49/qt/runanki.py
- source = https://raw.githubusercontent.com/ankitects/anki/2.1.49/qt/linux/anki.desktop
- source = https://raw.githubusercontent.com/ankitects/anki/2.1.49/qt/linux/anki.png
- sha256sums = 746c9807d5f2f87503eb993b28b660fd8e0bc70b969796855dbd48bdaa995af4
- sha256sums = e9aee6a19ab4f4cf7142f4ccf776a34245013d2800d873177854b0ec5dfb2411
- sha256sums = 520225521a013546c521c2c8d60db3d03d7fceb6126fa61b8a70e1d2c398e4a4
- sha256sums = 5121f5877cd6fe15e262317eb2ac08a01f7039e3fd5d85e3193b4b0ff7974e13
+ source = https://files.pythonhosted.org/packages/cp39/a/anki/anki-2.1.50-cp39-abi3-manylinux_2_28_x86_64.whl
+ source = https://files.pythonhosted.org/packages/py3/a/aqt/aqt-2.1.50-py3-none-any.whl
+ source = https://raw.githubusercontent.com/ankitects/anki/2.1.50/qt/runanki.py
+ source = https://raw.githubusercontent.com/ankitects/anki/2.1.50/qt/bundle/lin/anki.desktop
+ source = https://raw.githubusercontent.com/ankitects/anki/2.1.50/qt/bundle/lin/anki.png
+ sha256sums = 0f1dbcaf89a7584e6ebef848a7abad6f008f4be882d634bc245a0e2bddfc18c6
+ sha256sums = 5b2d10e940dbc82c584bb9cb5657ad70a9bdfebb70bc82f4b1f90052184d6355
+ sha256sums = 9648e7e915f51f08e05c48ef5f39b4015922fe1cf3d7f2895535ef10ef4507ae
+ sha256sums = 53db2e5bfeb00aa249667e09466a34bfacb17b61097875a8cdd93ee1a9380b9a
sha256sums = 97ad2134ef1a7686789c7becd8bd05dd8693cf0d3127951ca6ba7b29a80b402a
pkgname = anki-bin
diff --git a/PKGBUILD b/PKGBUILD
index c8e8a96803ae..45b6da32a13c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
_anki=anki
_aqt=aqt
-_py=cp38
+_py=cp39
pkgname=anki-bin
-pkgver=2.1.49
+pkgver=2.1.50
pkgrel=1
pkgdesc='Helps you remember facts (like words/phrases in a foreign language) efficiently.
Installed with wheel.'
@@ -26,6 +26,7 @@ depends=(
'python-pyqtwebengine'
'python-send2trash'
'python-waitress'
+ 'python-pyqt6-webengine'
# anki
'python-decorator'
@@ -49,17 +50,17 @@ optdepends=(
provides=(anki=$pkgver)
conflicts=(anki)
source=(
- "https://files.pythonhosted.org/packages/$_py/${_anki::1}/$_anki/$_anki-$pkgver-$_py-abi3-manylinux2014_$arch.whl"
+ "https://files.pythonhosted.org/packages/$_py/${_anki::1}/$_anki/$_anki-$pkgver-$_py-abi3-manylinux_2_28_$arch.whl"
"https://files.pythonhosted.org/packages/py3/${_aqt::1}/$_aqt/$_aqt-$pkgver-py3-none-any.whl"
"https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/runanki.py"
- "https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/linux/anki.desktop"
- "https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/linux/anki.png"
+ "https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/bundle/lin/anki.desktop"
+ "https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/bundle/lin/anki.png"
)
noextract=("${source[@]##*/}")
-sha256sums=('746c9807d5f2f87503eb993b28b660fd8e0bc70b969796855dbd48bdaa995af4'
- 'e9aee6a19ab4f4cf7142f4ccf776a34245013d2800d873177854b0ec5dfb2411'
- '520225521a013546c521c2c8d60db3d03d7fceb6126fa61b8a70e1d2c398e4a4'
- '5121f5877cd6fe15e262317eb2ac08a01f7039e3fd5d85e3193b4b0ff7974e13'
+sha256sums=('0f1dbcaf89a7584e6ebef848a7abad6f008f4be882d634bc245a0e2bddfc18c6'
+ '5b2d10e940dbc82c584bb9cb5657ad70a9bdfebb70bc82f4b1f90052184d6355'
+ '9648e7e915f51f08e05c48ef5f39b4015922fe1cf3d7f2895535ef10ef4507ae'
+ '53db2e5bfeb00aa249667e09466a34bfacb17b61097875a8cdd93ee1a9380b9a'
'97ad2134ef1a7686789c7becd8bd05dd8693cf0d3127951ca6ba7b29a80b402a')
package() {