summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorescape07072022-06-01 10:53:58 +0900
committerescape07072022-06-01 10:53:58 +0900
commitb91eee592b6da0fde52d8d7d9dfaa1280e9bb355 (patch)
treebda4e6ac85bab92f07ce37786fc2476347b0d28d
parent5252381021b6ed7e863b5016c532b00ceb7e85a9 (diff)
downloadaur-b91eee592b6da0fde52d8d7d9dfaa1280e9bb355.tar.gz
Name auxiliary files with pkgver after downloading
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cc810f6d1f3..1ad5458c79c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,9 +33,9 @@ pkgbase = anki-bin
noextract = anki.png
source = https://files.pythonhosted.org/packages/cp39/a/anki/anki-2.1.53-cp39-abi3-manylinux_2_28_x86_64.whl
source = https://files.pythonhosted.org/packages/py3/a/aqt/aqt-2.1.53-py3-none-any.whl
- source = https://raw.githubusercontent.com/ankitects/anki/2.1.53/qt/runanki.py
- source = https://raw.githubusercontent.com/ankitects/anki/2.1.53/qt/bundle/lin/anki.desktop
- source = https://raw.githubusercontent.com/ankitects/anki/2.1.53/qt/bundle/lin/anki.png
+ source = runanki-2.1.53.py::https://raw.githubusercontent.com/ankitects/anki/2.1.53/qt/runanki.py
+ source = anki-2.1.53.desktop::https://raw.githubusercontent.com/ankitects/anki/2.1.53/qt/bundle/lin/anki.desktop
+ source = anki-2.1.53.png::https://raw.githubusercontent.com/ankitects/anki/2.1.53/qt/bundle/lin/anki.png
sha256sums = 54f1b28b0c7f83bab0a009255741e9ec02ccfaf19c6a99e5ed50c5a91eb3caf4
sha256sums = d12c1b29a6c6c024a99472e8501718c8ab3046eddc98e4e02b8b0eb0afea5c53
sha256sums = 9648e7e915f51f08e05c48ef5f39b4015922fe1cf3d7f2895535ef10ef4507ae
diff --git a/PKGBUILD b/PKGBUILD
index f78da6e38fb5..010dbcd2fd9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,9 +50,9 @@ conflicts=(anki)
source=(
"https://files.pythonhosted.org/packages/$_py/${_anki::1}/$_anki/$_anki-$pkgver-$_py-abi3-manylinux_2_28_$arch.whl"
"https://files.pythonhosted.org/packages/py3/${_aqt::1}/$_aqt/$_aqt-$pkgver-py3-none-any.whl"
- "https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/runanki.py"
- "https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/bundle/lin/anki.desktop"
- "https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/bundle/lin/anki.png"
+ "runanki-$pkgver.py::https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/runanki.py"
+ "anki-$pkgver.desktop::https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/bundle/lin/anki.desktop"
+ "anki-$pkgver.png::https://raw.githubusercontent.com/ankitects/anki/$pkgver/qt/bundle/lin/anki.png"
)
noextract=("${source[@]##*/}")
sha256sums=('54f1b28b0c7f83bab0a009255741e9ec02ccfaf19c6a99e5ed50c5a91eb3caf4'
@@ -64,7 +64,7 @@ sha256sums=('54f1b28b0c7f83bab0a009255741e9ec02ccfaf19c6a99e5ed50c5a91eb3caf4'
package() {
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
- install -Dm755 runanki.py "$pkgdir/usr/bin/anki"
- install -Dm644 anki.desktop "$pkgdir/usr/share/applications/anki.desktop"
- install -Dm644 anki.png "$pkgdir/usr/share/pixmaps/anki.png"
+ install -Dm755 runanki-$pkgver.py "$pkgdir/usr/bin/anki"
+ install -Dm644 anki-$pkgver.desktop "$pkgdir/usr/share/applications/anki.desktop"
+ install -Dm644 anki-$pkgver.png "$pkgdir/usr/share/pixmaps/anki.png"
}