summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2018-03-05 20:08:41 +0100
committerRaimar Bühmann2018-03-05 20:09:56 +0100
commit351e864950604c70b69f226abc419f2ed1d7e833 (patch)
tree6f80566ad64e9a0224b0b90a74487a9f713c04ad
parent10a78e32c7a77a66ce26fb1a7dcc451675641f6c (diff)
downloadaur-351e864950604c70b69f226abc419f2ed1d7e833.tar.gz
update to version 0.3.0.r40.20180115
* Created sub package libankidrive-git.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 36 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 478a45642d66..7b25670074ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,5 @@
pkgbase = anki-drive-sdk-git
- pkgdesc = C implementation of message protocols and data parsing to communicate with Anki Drive vehicles
- pkgver = 0.3.0.r38.20170808
+ pkgver = 0.3.0.r40.20180115
pkgrel = 1
url = https://github.com/anki/drive-sdk
arch = i686
@@ -8,10 +7,18 @@ pkgbase = anki-drive-sdk-git
license = Apache
makedepends = cmake
makedepends = gcc
- depends = glib2
- optdepends = bluez-utils: for command line tool hciconfig
+ optdepends = bluez-utils: for command line tool btmgmt (hciconfig is deprecated)
source = anki-drive-sdk-git::git+https://github.com/anki/drive-sdk.git
md5sums = SKIP
pkgname = anki-drive-sdk-git
+ pkgdesc = C SDK for message protocols and data parsing to communicate with Anki Drive vehicles
+ depends = libankidrive
+
+pkgname = libankidrive-git
+ pkgdesc = C library of message protocols and data parsing to communicate with Anki Drive vehicles
+ depends = glib2
+ provides = libankidrive
+ conflicts = libankidrive
+ replaces = libankidrive
diff --git a/PKGBUILD b/PKGBUILD
index f6154714f84e..ea8cd71264b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,12 @@
# Maintainer: Raimar Bühmann <raimar _at_ buehmann _dot_ de>
-pkgname=anki-drive-sdk-git
-pkgver=0.3.0.r38.20170808
+pkgname=('anki-drive-sdk-git' 'libankidrive-git')
+pkgver=0.3.0.r40.20180115
pkgrel=1
-pkgdesc="C implementation of message protocols and data parsing to communicate with Anki Drive vehicles"
arch=('i686' 'x86_64')
url="https://github.com/anki/drive-sdk"
license=('Apache')
-depends=('glib2')
-optdepends=('bluez-utils: for command line tool hciconfig')
+optdepends=('bluez-utils: for command line tool btmgmt (hciconfig is deprecated)')
makedepends=('cmake' 'gcc')
source=(
"$pkgname::git+https://github.com/anki/drive-sdk.git"
@@ -29,17 +27,32 @@ prepare() {
cd $pkgname
}
build() {
- cd "$pkgname"
+ echo "BUILD..."
+ cd "$pkgbase"
mkdir -p build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX= -DBUILD_EXAMPLES=ON
- make
}
package() {
- cd "$pkgname/build"
+ install -Dm644 "../../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+package_anki-drive-sdk-git() {
+ pkgdesc="C SDK for message protocols and data parsing to communicate with Anki Drive vehicles"
+ depends=('libankidrive')
+ cd "$pkgbase/build/examples"
+ make DESTDIR="${pkgdir}/usr" install
+ package
+}
+package_libankidrive-git() {
+ pkgdesc="C library of message protocols and data parsing to communicate with Anki Drive vehicles"
+ depends=('glib2')
+ conflicts=('libankidrive')
+ replaces=('libankidrive')
+ provides=('libankidrive')
+ cd "$pkgbase/build/src"
make DESTDIR="${pkgdir}/usr" install
- install -Dm644 '../include/ankidrive.h' "${pkgdir}/usr/include/ankidrive.h"
- # delete hciconfig, because it is already included in optional package bluez-utils
- rm "${pkgdir}/usr/bin/hciconfig"
- install -Dm644 '../LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 '../../include/ankidrive.h' "${pkgdir}/usr/include/ankidrive.h"
+ install -dm755 "${pkgdir}/usr/include/ankidrive"
+ cp -a ../../include/ankidrive/*.h "${pkgdir}/usr/include/ankidrive/."
+ package
}