summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Egeberg2017-02-12 12:50:41 +0100
committerDaniel Egeberg2017-02-12 12:50:41 +0100
commit21aaf26ecb3560d77f0822f7b1a21ff544fea473 (patch)
tree578b380a915db94f555d7404d622e692c523605f
downloadaur-21aaf26ecb3560d77f0822f7b1a21ff544fea473.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa7afa298a3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Feb 12 11:50:17 UTC 2017
+pkgbase = anki-git
+ pkgdesc = Helps you remember facts (like words/phrases in a foreign language) efficiently
+ pkgver = r1122.6df5ce7
+ pkgrel = 1
+ url = http://ankisrs.net/
+ arch = any
+ license = AGPL3
+ depends = python-pyqt5
+ depends = python-beautifulsoup4
+ depends = python-httplib2
+ depends = python-pyaudio
+ depends = python-requests
+ depends = python-send2trash
+ optdepends = mplayer: sound playing
+ provides = anki
+ conflicts = anki
+ conflicts = anki20
+ source = anki-git::git+https://github.com/dae/anki.git
+ sha512sums = SKIP
+
+pkgname = anki-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ee1f394c7fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+anki-git
+pkg
+*.pkg.tar*
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8bb5cfb4a39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Daniel Egeberg <daniel.egeberg@gmail.com
+# Contributor: SÅ‚awomir Kowalski <suawekk+aur@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Timm Preetz <timm@preetz.us>
+# Contributor: Michael 'manveru' Fellinger <m.fellinger@gmail.com>
+# Contributor: Dave Pretty <david dot pretty at gmail dot com>
+
+pkgname=anki-git
+pkgver=r1122.6df5ce7
+pkgrel=1
+pkgdesc="Helps you remember facts (like words/phrases in a foreign language) efficiently"
+url="http://ankisrs.net/"
+license=('AGPL3')
+arch=('any')
+provides=('anki')
+conflicts=('anki' 'anki20')
+depends=('python-pyqt5' 'python-beautifulsoup4' 'python-httplib2' 'python-pyaudio' 'python-requests' 'python-send2trash')
+optdepends=('mplayer: sound playing')
+source=("${pkgname}::git+https://github.com/dae/anki.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ msg2 "Building UI"
+ ./tools/build_ui.sh
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ mkdir -p "$pkgdir"/usr/{bin,share/{anki,pixmaps,applications,man/man1}}
+ cp -av * "$pkgdir"/usr/share/anki/
+ cd "$pkgdir"/usr/share/anki && (
+ mv tools/runanki.system ../../bin/anki
+ mv anki.xpm anki.png ../pixmaps/
+ mv anki.desktop ../applications/
+ mv anki.1 ../man/man1/
+ )
+ rm -rf "$pkgdir"/usr/share/anki/{tests,thirdparty/[!s]*,tools,anki.bat,runanki}
+
+ msg2 "Precompiling python files"
+ python -m compileall -q "${pkgdir}/usr/share/anki"
+}