summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuklin István Alexander2022-06-19 20:22:20 +0200
committerKuklin István Alexander2022-06-19 20:22:20 +0200
commit445f1780bb7176e1e0daebf510a2f4bdca7ca5ba (patch)
treefa5bf1151237f87a62ba41671062cc972bfdc290
parentedaf18ecc5c0e2ad53dfbd0b09334c3513de55df (diff)
downloadaur-445f1780bb7176e1e0daebf510a2f4bdca7ca5ba.tar.gz
2.1.53
-rw-r--r--.SRCINFO8
-rw-r--r--Dockerfile16
-rw-r--r--PKGBUILD24
-rw-r--r--docker.sudoers1
-rw-r--r--install_sh.patch26
5 files changed, 29 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8855a5e6e1d..55afe04f4c45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anki-official-binary-bundle
pkgdesc = The official binary shipped with the tested versions of the dependent libraries.
- pkgver = 2.1.49
+ pkgver = 2.1.53
pkgrel = 1
url = https://apps.ankiweb.net
arch = x86_64
@@ -10,9 +10,9 @@ pkgbase = anki-official-binary-bundle
provides = anki
conflicts = anki
conflicts = anki-git
- source = https://github.com/ankitects/anki/releases/download/2.1.49/anki-2.1.49-linux.tar.bz2
+ source = https://github.com/ankitects/anki/releases/download/2.1.53/anki-2.1.53-linux-qt6.tar.zst
source = install_sh.patch
- md5sums = d0c13ae7cf988358fb231645f6490088
- md5sums = 82d6fb7eb10ec0ae592093d89d8d5957
+ sha256sums = c9739271c6f2bfbe248c98fd83d5ce8952301f21ac39f2c0504219294557ddfc
+ sha256sums = b6dc61727ad2c2e10fb49cb58d1cd9900aa15eaba525117299a2143ad2745868
pkgname = anki-official-binary-bundle
diff --git a/Dockerfile b/Dockerfile
deleted file mode 100644
index 9422cfca565c..000000000000
--- a/Dockerfile
+++ /dev/null
@@ -1,16 +0,0 @@
-FROM archlinux
-
-# https://serverfault.com/a/1053273
-# TEMP-FIX for pacman issue
-RUN patched_glibc=glibc-linux4-2.33-4-x86_64.pkg.tar.zst \
- && curl -LO "https://raw.githubusercontent.com/sickcodes/Docker-OSX/master/${patched_glibc}" \
- && bsdtar -C / -xvf "${patched_glibc}" || echo "Everything is fine."
-# TEMP-FIX for pacman issue
-
-RUN pacman -Sy --noconfirm sudo fakeroot base-devel
-RUN pacman -S --noconfirm git
-RUN pacman -S --noconfirm vim
-COPY docker.sudoers /etc/sudoers.d/wheel
-RUN useradd user
-RUN usermod -a user -G wheel
-
diff --git a/PKGBUILD b/PKGBUILD
index b7152679902d..af9fcb22bc7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Kuklin István <kuklinistvan@zoho.com>
pkgname=anki-official-binary-bundle
-pkgver=2.1.49
+pkgver=2.1.53
pkgrel=1
epoch=
pkgdesc="The official binary shipped with the tested versions of the dependent libraries."
@@ -22,31 +22,25 @@ conflicts=('anki' 'anki-git')
replaces=()
backup=()
options=()
-install=
+install=$pkgname.install
changelog=
-topdirname="anki-$pkgver-linux"
+topdirname="anki-$pkgver-linux-qt6"
source=(
- "https://github.com/ankitects/anki/releases/download/${pkgver}/${topdirname}.tar.bz2"
+ "https://github.com/ankitects/anki/releases/download/${pkgver}/${topdirname}.tar.zst"
"install_sh.patch"
)
noextract=()
-md5sums=('d0c13ae7cf988358fb231645f6490088'
- '82d6fb7eb10ec0ae592093d89d8d5957')
+sha256sums=('c9739271c6f2bfbe248c98fd83d5ce8952301f21ac39f2c0504219294557ddfc'
+ '991297cb02434d753f55980205a22971ed98655b0f62f0104ae4692155355d8c')
validpgpkeys=()
prepare() {
- cd "$srcdir"
- ln -s "$topdirname" anki
- patch -p0 -i install_sh.patch anki/install.sh
- rm anki
-}
-
-build() {
- cd "$topdirname"
+ cd "$srcdir"/"$topdirname"
+ patch install.sh ../install_sh.patch
}
package() {
cd "$topdirname"
- PREFIX="$pkgdir"/usr/ ./install.sh
+ PREFIX="$pkgdir"/usr/ ./install.sh
}
diff --git a/docker.sudoers b/docker.sudoers
deleted file mode 100644
index 7c499c26cff3..000000000000
--- a/docker.sudoers
+++ /dev/null
@@ -1 +0,0 @@
-%wheel ALL=(ALL) NOPASSWD: ALL
diff --git a/install_sh.patch b/install_sh.patch
index 3dc6095f494b..e76e1affe70b 100644
--- a/install_sh.patch
+++ b/install_sh.patch
@@ -1,21 +1,27 @@
---- install.sh.orig 2020-12-10 06:36:44.000000000 +0100
-+++ install.sh 2020-12-30 14:54:50.834734784 +0100
-@@ -15,7 +15,7 @@
+--- install.sh.orig 2022-06-06 18:29:11.117752422 -0500
++++ install.sh 2022-06-06 18:40:38.153466913 -0500
+@@ -13,9 +13,10 @@
+
+ rm -rf "$PREFIX"/share/anki "$PREFIX"/bin/anki
mkdir -p "$PREFIX"/share/anki
- cp -av * "$PREFIX"/share/anki/
+-cp -av --no-preserve=owner,context * "$PREFIX"/share/anki/
++shopt -s extglob
++cp -av --no-preserve=owner,context !(*install.sh) "$PREFIX"/share/anki/
mkdir -p "$PREFIX"/bin
--ln -sf "$PREFIX"/share/anki/bin/Anki "$PREFIX"/bin/anki
-+ln -sf /usr/share/anki/bin/Anki "$PREFIX"/bin/anki
+-ln -sf "$PREFIX"/share/anki/anki "$PREFIX"/bin/anki
++ln -sf ../share/anki/anki "$PREFIX"/bin/anki
# fix a previous packaging issue where we created this as a file
(test -f "$PREFIX"/share/applications && rm "$PREFIX"/share/applications)||true
mkdir -p "$PREFIX"/share/pixmaps
-@@ -26,9 +26,4 @@
- mv anki.desktop "$PREFIX"/share/applications/;\
- mv anki.1 "$PREFIX"/share/man/man1/)
-
+@@ -26,11 +26,4 @@
+ mv -Z anki.desktop "$PREFIX"/share/applications/;\
+ mv -Z anki.1 "$PREFIX"/share/man/man1/)
+
-xdg-mime install anki.xml --novendor
-xdg-mime default anki.desktop application/x-colpkg
-xdg-mime default anki.desktop application/x-apkg
-xdg-mime default anki.desktop application/x-ankiaddon
-
+-rm install.sh
+-
echo "Install complete. Type 'anki' to run."