summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuklin István2019-03-04 19:43:30 +0100
committerKuklin István2019-03-04 19:46:02 +0100
commitb11ec067244dd6e8f80cdd5dd7f71b1057cb7f30 (patch)
tree11cc13328f8fb868919196cd59a1ca84c0cd83a8
parent452f5544c43a2417efc5a8a792e3cd493debcc22 (diff)
downloadaur-b11ec067244dd6e8f80cdd5dd7f71b1057cb7f30.tar.gz
Link path fix
-rw-r--r--PKGBUILD15
-rw-r--r--prefix-fix.patch11
2 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8be4c2d9344..9d99d6ed27e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: Kuklin István <kuklinistvan@zoho.com>
pkgname=anki-official-binary-bundle
pkgver=2.1.9
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="The official binary shipped with the tested versions of the dependent libraries."
arch=('x86_64')
@@ -25,14 +25,16 @@ options=()
install=
changelog=
topdirname="anki-$pkgver-linux-amd64"
-source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch")
+source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch" "prefix-fix.patch")
noextract=()
-md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f')
+md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f'
+ '5968099e737668ad7134edfd8bc6f323')
validpgpkeys=()
prepare() {
cd "$srcdir"
patch -p0 -i remove_xdg_cmds_from_makefile.patch
+ patch -p0 -i prefix-fix.patch
}
build() {
@@ -40,12 +42,7 @@ build() {
make
}
-# check() {
-# cd "$topdirname"
-# make -k check
-# }
-
package() {
cd "$topdirname"
- make PREFIX="$pkgdir/usr" install
+ make PREFIX="$pkgdir/usr/" install
}
diff --git a/prefix-fix.patch b/prefix-fix.patch
new file mode 100644
index 000000000000..f462e060e23a
--- /dev/null
+++ b/prefix-fix.patch
@@ -0,0 +1,11 @@
+--- anki-2.1.9-linux-amd64/Makefile.orig 2019-03-04 19:24:16.040322000 +0100
++++ anki-2.1.9-linux-amd64/Makefile 2019-03-04 19:29:45.048864131 +0100
+@@ -10,7 +10,7 @@
+ mkdir -p ${PREFIX}/share/anki
+ cp -av * ${PREFIX}/share/anki/
+ mkdir -p ${PREFIX}/bin
+- ln -sf ${PREFIX}/share/anki/bin/anki ${PREFIX}/bin/
++ ln -sf /usr/share/anki/bin/anki ${PREFIX}/bin/
+ # fix a previous packaging issue where we created this as a file
+ (test -f ${PREFIX}/share/applications && rm ${PREFIX}/share/applications)||true
+ mkdir -p ${PREFIX}/share/pixmaps