summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-05-15 10:22:41 +0200
committerAlexBocken2023-05-15 10:22:41 +0200
commit5268a7548a19c94b1167f9a98ceeb577d18e9a17 (patch)
tree50c3a6367c5ecc64d1685e737fba418bbcdf8dbb
parentbd4f2358793525d783ba5d9b643c8f83daaa4bf3 (diff)
downloadaur-5268a7548a19c94b1167f9a98ceeb577d18e9a17.tar.gz
bump to 2.1.63, use local python and protoc
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--no-update.patch2
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93aa925bc48d..2e70eb114408 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anki-qt5
pkgdesc = Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build
- pkgver = 2.1.62
- pkgrel = 2
+ pkgver = 2.1.63
+ pkgrel = 1
url = https://apps.ankiweb.net/
arch = x86_64
license = AGPL3
@@ -33,19 +33,17 @@ pkgbase = anki-qt5
optdepends = mplayer: play sound
optdepends = texlive-most: render LaTex in cards
provides = anki
- provides = anki-debug
conflicts = anki
conflicts = anki-bin
conflicts = anki-git
conflicts = anki-official-binary-bundle
- conflicts = anki-debug
options = !lto
- source = anki-qt5::git+https://github.com/ankitects/anki#tag=2fa41836272c034af40f59b263429d246a7b47af?signed
+ source = anki-qt5::git+https://github.com/ankitects/anki#tag=064ea0ee08715edae868b84e48b29bd7e15d7b49?signed
source = no-update.patch
source = force_qt5.patch
validpgpkeys = 814EA4E90C34AF39A712DE703F5566A2D16899FB
sha256sums = SKIP
- sha256sums = 137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797
+ sha256sums = f934553a5ce9e046a0b8253e10da16e661b27375e2b54d6bb915267f32aff807
sha256sums = c5e6e1b2ed7999e9ef7f855aed4c97c4ace846237421507f408a64a8258a09fd
pkgname = anki-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 65e1a93c281f..1543bd7a78d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,15 @@
# Contributor: Dave Pretty <david dot pretty at gmail dot com>
pkgname=anki-qt5
-pkgver=2.1.62
-_tag=2fa41836272c034af40f59b263429d246a7b47af #git rev-parse $pkgver
-pkgrel=2
+pkgver=2.1.63
+_tag=064ea0ee08715edae868b84e48b29bd7e15d7b49 #git rev-parse $pkgver
+pkgrel=1
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build"
url="https://apps.ankiweb.net/"
license=('AGPL3')
arch=('x86_64')
-provides=('anki' anki-debug)
-conflicts=('anki' 'anki-bin' 'anki-git' 'anki-official-binary-bundle' 'anki-debug')
+provides=('anki')
+conflicts=('anki' 'anki-bin' 'anki-git' 'anki-official-binary-bundle')
options=('!lto')
depends=(
# anki & aqt
@@ -64,7 +64,7 @@ source=("$pkgname::git+https://github.com/ankitects/anki#tag=${_tag}?signed"
"force_qt5.patch"
)
sha256sums=('SKIP'
-'137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797'
+'f934553a5ce9e046a0b8253e10da16e661b27375e2b54d6bb915267f32aff807'
'c5e6e1b2ed7999e9ef7f855aed4c97c4ace846237421507f408a64a8258a09fd'
)
@@ -82,6 +82,12 @@ prepare(){
build() {
cd "$pkgname"
+
+ #use local binaries instead of downloading them as well for python and protoc
+ export PYTHON_BINARY=$(type python | cut -d' ' -f1,2 --complement)
+ export PROTOC_BINARY=$(type protoc | cut -d' ' -f1,2 --complement)
+ #export NODE_BINARY=$(type node | cut -d' ' -f1,2 --complement) # does not yet compile
+
./tools/build
}
diff --git a/no-update.patch b/no-update.patch
index 2c6e36520239..7a41ad13d3f5 100644
--- a/no-update.patch
+++ b/no-update.patch
@@ -1,6 +1,6 @@
--- a/qt/aqt/update.py
+++ b/qt/aqt/update.py
-@@ -34,6 +34,8 @@
+@@ -33,6 +33,8 @@
}
def run(self) -> None: