summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-04-02 15:03:15 +0200
committerAlexBocken2023-04-02 15:03:15 +0200
commit844527ddc66ed19213dbaa96444bb50c886348f5 (patch)
treec35e462b6d5975a9aaa1be2c81b5fd7e95505b69
parentd02cd8c6a414070241e21edba3e937ed2af1310d (diff)
downloadaur-844527ddc66ed19213dbaa96444bb50c886348f5.tar.gz
add pgp key, move to tag commit hash
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3e5995fc9a4..ff8f1851e263 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -40,9 +40,10 @@ pkgbase = anki-qt5
conflicts = anki-official-binary-bundle
conflicts = anki-debug
options = !lto
- source = anki::git+https://github.com/ankitects/anki#tag=2.1.61
+ source = anki-qt5::git+https://github.com/ankitects/anki#tag=00556663989832a51b24da237ef3be77677c1bb6?signed
source = no-update.patch
source = force_qt5.patch
+ validpgpkeys = 814EA4E90C34AF39A712DE703F5566A2D16899FB
sha256sums = SKIP
sha256sums = 137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797
sha256sums = c5e6e1b2ed7999e9ef7f855aed4c97c4ace846237421507f408a64a8258a09fd
diff --git a/PKGBUILD b/PKGBUILD
index ac4ea0d8a123..908e50ece110 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@
pkgname=anki-qt5
pkgver=2.1.61
+_tag=00556663989832a51b24da237ef3be77677c1bb6 #git rev-parse $pkgver
pkgrel=1
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build"
url="https://apps.ankiweb.net/"
@@ -58,7 +59,7 @@ optdepends=(
# using the tag tarballs does not work with the new (>= 2.1.55) build process.
# the '.git' folder is not included in those but is required for a sucessful build
-source=("anki::git+https://github.com/ankitects/anki#tag=${pkgver}"
+source=("$pkgname::git+https://github.com/ankitects/anki#tag=${_tag}?signed"
"no-update.patch"
"force_qt5.patch"
)
@@ -67,9 +68,12 @@ sha256sums=('SKIP'
'c5e6e1b2ed7999e9ef7f855aed4c97c4ace846237421507f408a64a8258a09fd'
)
+validpgpkeys=(
+ 814EA4E90C34AF39A712DE703F5566A2D16899FB # Anki Signatures <gpg@ankiweb.net>
+)
prepare(){
- cd "anki"
+ cd "$pkgname"
# pro-actively prevent "module not found" error
[ -d ts/node_modules ] && rm -r ts/node_modules
patch -p1 < "$srcdir/no-update.patch"
@@ -77,12 +81,17 @@ prepare(){
}
build() {
- cd "anki"
+ cd "$pkgname"
./tools/build
}
+pkgver(){
+ cd "$pkgname"
+ git describe
+}
+
package() {
- cd "anki"
+ cd "$pkgname"
for file in out/wheels/*.whl; do
python -m installer --destdir="$pkgdir" $file
done