summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-02-22 13:07:17 +0100
committerAlexBocken2023-02-22 13:07:17 +0100
commit94dc7b7586d775dcd047480e1ccd2f0603fb06bd (patch)
treee22cbc9f3c2aaf5a5dc6166b80825953d7a9f2bb
parent50340ec82a81c63ac9fbdc0bf3ae6ca5d4cfa96c (diff)
downloadaur-94dc7b7586d775dcd047480e1ccd2f0603fb06bd.tar.gz
bump to 2.1.60, moved to "anki" srcdir to reduce space needed for updates
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2c327860375..c49ccb8b4e4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anki-qt5
pkgdesc = Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build
- pkgver = 2.1.58
+ pkgver = 2.1.60
pkgrel = 1
url = https://apps.ankiweb.net/
arch = x86_64
@@ -39,7 +39,7 @@ pkgbase = anki-qt5
conflicts = anki-git
conflicts = anki-official-binary-bundle
options = !lto
- source = anki-2.1.58::git+https://github.com/ankitects/anki#tag=2.1.58
+ source = anki::git+https://github.com/ankitects/anki#tag=2.1.60
source = no-update.patch
source = force_qt5.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5a50461466a0..b45482c29193 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Dave Pretty <david dot pretty at gmail dot com>
pkgname=anki-qt5
-pkgver=2.1.58
+pkgver=2.1.60
pkgrel=1
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build"
url="https://apps.ankiweb.net/"
@@ -59,7 +59,7 @@ optdepends=(
# using the tag tarballs does not work with the new (>= 2.1.55) build process.
# the '.git' folder is not included in those but is required for a sucessful build
-source=("anki-${pkgver}::git+https://github.com/ankitects/anki#tag=${pkgver}"
+source=("anki::git+https://github.com/ankitects/anki#tag=${pkgver}"
"no-update.patch"
"force_qt5.patch"
)
@@ -70,7 +70,7 @@ sha256sums=('SKIP'
prepare(){
- cd "anki-$pkgver"
+ cd "anki"
# pro-actively prevent "module not found" error
[ -d ts/node_modules ] && rm -r ts/node_modules
patch -p1 < "$srcdir/no-update.patch"
@@ -78,12 +78,12 @@ prepare(){
}
build() {
- cd "anki-$pkgver"
+ cd "anki"
./tools/build
}
package() {
- cd "anki-$pkgver"
+ cd "anki"
for file in out/wheels/*.whl; do
python -m installer --destdir="$pkgdir" $file
done