summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-05-16 09:48:38 +0200
committerAlexBocken2023-05-16 09:48:38 +0200
commita358bbdca54204a510eccbdf63375f5e85e99e6a (patch)
tree16844170330558553135c7bff912ec362246ff00
parent5268a7548a19c94b1167f9a98ceeb577d18e9a17 (diff)
downloadaur-a358bbdca54204a510eccbdf63375f5e85e99e6a.tar.gz
use `which` to get python and protoc bins
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1543bd7a78d5..4971c8aa80dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -84,9 +84,9 @@ build() {
cd "$pkgname"
#use local binaries instead of downloading them as well for python and protoc
- export PYTHON_BINARY=$(type python | cut -d' ' -f1,2 --complement)
- export PROTOC_BINARY=$(type protoc | cut -d' ' -f1,2 --complement)
- #export NODE_BINARY=$(type node | cut -d' ' -f1,2 --complement) # does not yet compile
+ export PYTHON_BINARY=$(which python)
+ export PROTOC_BINARY=$(which protoc)
+ #export NODE_BINARY=$(which node) # does not yet compile
./tools/build
}