summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-03-31 11:53:40 +0200
committerAlexBocken2023-03-31 11:53:40 +0200
commitd02cd8c6a414070241e21edba3e937ed2af1310d (patch)
tree08560c5757f6ee4dbb92c25a7201ee4674375f08
parent94dc7b7586d775dcd047480e1ccd2f0603fb06bd (diff)
downloadaur-d02cd8c6a414070241e21edba3e937ed2af1310d.tar.gz
bump to 2.1.61
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c49ccb8b4e4c..e3e5995fc9a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anki-qt5
pkgdesc = Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build
- pkgver = 2.1.60
+ pkgver = 2.1.61
pkgrel = 1
url = https://apps.ankiweb.net/
arch = x86_64
@@ -12,34 +12,35 @@ pkgbase = anki-qt5
makedepends = python-installer
makedepends = libxcrypt-compat
makedepends = nodejs
+ depends = python>=3.9
depends = python-beautifulsoup4
- depends = python-waitress
+ depends = python-waitress>=2.0.0
+ depends = python-requests
depends = python-decorator
depends = python-markdown
depends = python-orjson
- depends = python-protobuf
+ depends = python-protobuf>=4.21
depends = python-pysocks
depends = python-distro
depends = python-flask-cors
depends = python-jsonschema
- depends = python-requests
depends = python-send2trash
- depends = python-flask-cors
depends = python-certifi
- depends = python-waitress
- depends = python-pyqt5
+ depends = python-pyqt5>=5.14
depends = qt5-svg
optdepends = lame: record sound
optdepends = mpv: play sound. prefered over mplayer
optdepends = mplayer: play sound
optdepends = texlive-most: render LaTex in cards
provides = anki
+ provides = anki-debug
conflicts = anki
conflicts = anki-bin
conflicts = anki-git
conflicts = anki-official-binary-bundle
+ conflicts = anki-debug
options = !lto
- source = anki::git+https://github.com/ankitects/anki#tag=2.1.60
+ source = anki::git+https://github.com/ankitects/anki#tag=2.1.61
source = no-update.patch
source = force_qt5.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b45482c29193..ac4ea0d8a123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,37 +7,36 @@
# Contributor: Dave Pretty <david dot pretty at gmail dot com>
pkgname=anki-qt5
-pkgver=2.1.60
+pkgver=2.1.61
pkgrel=1
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build"
url="https://apps.ankiweb.net/"
license=('AGPL3')
arch=('x86_64')
-provides=('anki')
-conflicts=('anki' 'anki-bin' 'anki-git' 'anki-official-binary-bundle')
+provides=('anki' anki-debug)
+conflicts=('anki' 'anki-bin' 'anki-git' 'anki-official-binary-bundle' 'anki-debug')
options=('!lto')
depends=(
# anki & aqt
+ 'python>=3.9'
'python-beautifulsoup4'
- 'python-waitress'
+ 'python-waitress>=2.0.0'
+ 'python-requests'
# anki
'python-decorator'
'python-markdown'
'python-orjson'
- 'python-protobuf'
+ 'python-protobuf>=4.21'
'python-pysocks'
'python-distro'
#aqt
- 'python-flask-cors'
+ 'python-flask-cors' # python-flask required for anki & aqt but a dependency of -cors
'python-jsonschema'
- 'python-requests'
'python-send2trash'
- 'python-flask-cors' # python-flask required for anki & aqt but a dependency of -cors
'python-certifi'
- 'python-waitress'
- 'python-pyqt5'
+ 'python-pyqt5>=5.14'
'qt5-svg'
)