summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bocken2021-07-28 15:14:25 +0200
committerAlexander Bocken2021-07-28 15:14:25 +0200
commit9054a0b36e9db1b710052ebc0855de55cdae3fae (patch)
tree94821ae8d241b1d235d48a5b287163f7ad03ed57
parent33697d898ffb3d2bd899bc200795f4c2172d2da7 (diff)
downloadaur-9054a0b36e9db1b710052ebc0855de55cdae3fae.tar.gz
disable auto-update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--no-update.patch11
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e30bb04926b2..6bdae5f302a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anki-release-source
pkgdesc = The latest release building from source locally
pkgver = 2.1.44
- pkgrel = 3
+ pkgrel = 4
url = https://apps.ankiweb.net/
arch = x86_64
license = AGPL3
@@ -41,6 +41,8 @@ pkgbase = anki-release-source
conflicts = anki-git
conflicts = anki-official-binary-bundle
source = anki-release-source-2.1.44.tar.gz::https://github.com/ankitects/anki/archive/refs/tags/2.1.44.tar.gz
+ source = no-update.patch
sha256sums = c24c87aac042b3ac803ea22669091730a48b575ee9d9939672d46caf6d3287b5
+ sha256sums = 137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797
pkgname = anki-release-source
diff --git a/PKGBUILD b/PKGBUILD
index 51243c17199d..73680d4b692e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=anki-release-source
pkgver=2.1.44
-pkgrel=3
+pkgrel=4
pkgdesc="The latest release building from source locally"
url="https://apps.ankiweb.net/"
license=('AGPL3')
@@ -53,8 +53,17 @@ optdepends=(
'mpv: play sound. prefered over mplayer'
'mplayer: play sound'
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ankitects/anki/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('c24c87aac042b3ac803ea22669091730a48b575ee9d9939672d46caf6d3287b5')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ankitects/anki/archive/refs/tags/${pkgver}.tar.gz"
+"no-update.patch"
+)
+sha256sums=('c24c87aac042b3ac803ea22669091730a48b575ee9d9939672d46caf6d3287b5'
+'137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797'
+)
+
+prepare(){
+ cd "anki-$pkgver"
+ patch -p1 < "$srcdir/no-update.patch"
+}
build() {
cd "anki-$pkgver"
diff --git a/no-update.patch b/no-update.patch
new file mode 100644
index 000000000000..2c6e36520239
--- /dev/null
+++ b/no-update.patch
@@ -0,0 +1,11 @@
+--- a/qt/aqt/update.py
++++ b/qt/aqt/update.py
+@@ -34,6 +34,8 @@
+ }
+
+ def run(self) -> None:
++ return
++
+ if not self.config["updates"]:
+ return
+ d = self._data()