summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors7hoang2020-07-17 18:06:45 -0400
committers7hoang2020-07-17 19:41:44 -0400
commit05c7720f8c9c6867e2cd8011d333ae32628ab11f (patch)
tree5516f62b6be31a1088ab2e6834fcd9b118661b78
parent2178a10bb6883319d71b2567ac4767cfa78bfa00 (diff)
downloadaur-05c7720f8c9c6867e2cd8011d333ae32628ab11f.tar.gz
Move Bundled-Anki Python Dependencies To Pacman Optional List
Since pacman is the intended way to install python packages, I thought I should probably just move all of the stuff found in requirements.txt to the optional dependencies list. Originally this list contained all the stuff I found I needed to get it working by doing it manually on fresh installations of arch. I'm guessing that these extra things that weren't listed in the requirements.txt were probably covered via the packages I didn't have in my original optionals list. We'll see...
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f986d7080801..05d64d7666ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,22 +10,18 @@ provides=('anki-sync-server')
conflicts=('anki-sync-server')
depends=('python' 'python-pip')
makedepends=('portaudio' 'git')
-optdepends=('python-pyqt5: dependency of bundled anki client'
+optdepends=('python-pyqt5: dependency of bundled anki client'
'python-pyqtwebengine: dependency of bundled anki client'
-'python-decorator: dependency of bundled anki client'
'python-beautifulsoup4: dependency of bundled anki client'
-'python-markdown: dependency of bundled anki client'
-'python-requests: dependency of bundled anki client'
'python-send2trash: dependency of bundled anki client'
-'libvpx>=1.8.0-1: dependency of bundled anki client'
-'double-conversion>=3.1.4-1: dependency of bundled anki client'
-'qt5-base>=5.12.2-1.1: dependency of bundled anki client'
-'qt5ct>=0.38-1: dependency of bundled anki client'
-'qt5-svg>=5.12.2-1: dependency of bundled anki client'
-'portaudio: dependency of pyaudio which is a dependency of bundled anki'
+'python-pyaudio: dependency of bundled anki client'
+'python-requests: dependency of bundled anki client'
+'python-decorator: dependency of bundled anki client'
+'python-markdown: dependency of bundled anki client'
+'python-psutil: dependency of bundled anki client'
'mpv: optional dependency of bundled anki client'
-'python2-webob: if you want to run the server as a user other than the supplied anki-sync-server user'
-'python2-decorator: if you want to run the server as a user other than the supplied anki-sync-server user'
+'python-webob: if you want to run the server as a user other than the supplied anki-sync-server user'
+'python-decorator: if you want to run the server as a user other than the supplied anki-sync-server user'
)
install=anki-sync-server.install
source=('git+https://github.com/ankicommunity/anki-sync-server')