summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors7hoang2020-07-17 16:31:32 -0400
committers7hoang2020-07-17 19:41:44 -0400
commit16f0f5782e6502fdf44f244c277c6eb900ec0af3 (patch)
tree483693a4986c0249e6671b88d0463639051fd071
parent6f8179f5248051a0cd1ecc04bdb05ddf46b06da4 (diff)
downloadaur-16f0f5782e6502fdf44f244c277c6eb900ec0af3.tar.gz
Remove Optional Anki-Bundled Build Stuff And Move To Post-Install
Originally I left it as a hodgepodge of an install since I wasn't *really* sure what I was going for (leave it in or not). I've since decided to leave it out and let the user decide to install that stuff.
-rw-r--r--PKGBUILD16
-rw-r--r--anki-sync-server.install16
2 files changed, 8 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec4363aa7ee5..f986d7080801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,22 +64,6 @@ prepare() {
sed "12s|changeme|/opt/${pkgname%-git}|" plugins/systemd/anki-sync-server.service -i
}
-build() {
- cd "${pkgname%-git}"/anki-bundled
-
- #initialize anki-bundled
- git submodule update --init
-
- # get anki-bundled working
- if [ -z "$(echo 'python-pyqt5 python-pyqtwebengine qt5-base>=5.12.2-1.1 libvpx>=1.8.0-1
- double-conversion>=3.1.4-1 qt5ct>=0.38-1 qt5-svg>=5.12.2-1' | xargs pacman -T)" ]; then
- echo "found prerequisites to use bundled anki, setting up bundled anki"
- pip install --upgrade setuptools --user
- pip install -r requirements.txt --user
- bash tools/build_ui.sh
- fi
-}
-
package() {
cd "${pkgname%-git}"
mkdir "${pkgdir}"/opt
diff --git a/anki-sync-server.install b/anki-sync-server.install
index a3506b90e99b..7024ea42ce9f 100644
--- a/anki-sync-server.install
+++ b/anki-sync-server.install
@@ -14,7 +14,7 @@ post_install() {
sudo -u anki-sync-server pip install decorator --user
# post installation instructions
- cat << EOF
+ cat << EOF
=======================================================================
------------------
Post Installation:
@@ -76,17 +76,17 @@ for details.
------------------------
Run Bundled Anki Client:
------------------------
-execute:
+If you want to run the supplied anki client execute:
/opt/anki-sync-server/anki-bundled/runanki
-you'll need most of the optional dependencies installed before running it
-though.
+You'll need to install the listed requirements to get it running first:
+
+ cd /opt/anki-sync-server/anki-bundled
+ pip install -r requirements.txt --user
+ bash tools/build_ui.sh #for aqt dependency
+ sudo pacman -S python-pyqt5 python-pyqtwebengine
-Also "aqt.forms" is a module you'll have to build yourself using the following script:
-
- /opt/anki-sync-server/anki-bundled/tools/build_ui.sh
-
=======================================================================
EOF
}