summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors7hoang2019-10-25 16:22:14 -0400
committers7hoang2019-10-25 16:35:36 -0400
commit8f4088a0fd2a1b55827f09ce12f2060f3b83c599 (patch)
treef4f7cc7ef744f77f044103413dc94b2e48a22c17
parentb4fb81e9fe1760da46385bb0aedbaa646b5635e3 (diff)
downloadaur-8f4088a0fd2a1b55827f09ce12f2060f3b83c599.tar.gz
clarify webob and decorator dependency issue
-rw-r--r--PKGBUILD4
-rw-r--r--anki-sync-server.install15
2 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bce3fefa363a..6d822ef145a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: s7hoang <s7hoang at gmail dot com>
pkgname=anki-sync-server-git
-pkgver=r258.b9a1203
+pkgver=r259.7ef3d4f
pkgrel=1
pkgdesc="A sync server for anki using a forked version from github.com/tsudoko (orig:dsnopek)"
arch=('any')
@@ -19,6 +19,8 @@ optdepends=('python-pyqt5: dependency of bundled anki client'
'qt5-svg>=5.12.2-1: dependency of bundled anki client'
'portaudio: dependency of pyaudio which is a dependency of bundled anki'
'mpv: optional dependency of bundled anki client'
+'python2-webob: if you want to run the server as a user other than the supplied anki-sync-server user'
+'python2-decorator: if you want to run the server as a user other than the supplied anki-sync-server user'
)
install=anki-sync-server.install
source=('git+https://github.com/tsudoko/anki-sync-server')
diff --git a/anki-sync-server.install b/anki-sync-server.install
index 1b5933efc587..b5a880a2cfea 100644
--- a/anki-sync-server.install
+++ b/anki-sync-server.install
@@ -12,6 +12,7 @@ post_install() {
# install prerequisites as stated on the website
sudo -u anki-sync-server pip install -r /opt/anki-sync-server/anki-bundled/requirements.txt --user
sudo -u anki-sync-server pip install webob --user
+ sudo -u anki-sync-server pip install decorator --user
# post installation instructions
cat << EOF
@@ -54,9 +55,19 @@ To just run the server, go to:
then run:
- python -m ankisyncd
+ sudo -u anki-sync-server python -m ankisyncd
-The server is set to auto start on boot.
+if you run it as another user you may have to install some dependencies again:
+
+ pip install --user webob decorator
+
+or:
+
+ sudo pacman -S python2-webob python2-decorator
+
+=== (be aware you may have trouble with permissions on your auth.db if you run as different users!) ===
+
+The server is set to auto start via systemctl.
See:
systemctl status anki-sync-server