summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors7hoang2020-07-17 18:56:54 -0400
committers7hoang2020-07-17 19:41:44 -0400
commita59d6ac6a2c0145683456b99a89111e8c1db5e0b (patch)
treea21a1949ed17c61f5f12c080a2acd8ac6da02166
parent6881cbf51bf2f1fed4f401c9ffb90062000565d2 (diff)
downloadaur-a59d6ac6a2c0145683456b99a89111e8c1db5e0b.tar.gz
Readd The Build Step
It turns out that the module has to be at least initialized and updated in order for the server to work.
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05d64d7666ea..13104664709f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build(){
+ #initialize anki-bundled (needed for the server to work)
+ cd "${pkgname%-git}"/anki-bundled && git submodule update --init
+}
+
prepare() {
# move plugins and systemd file to src package
mkdir -p "${pkgname%-git}/plugins/anki2.0"