summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors7hoang2020-05-25 12:37:47 -0400
committers7hoang2020-05-29 09:59:56 -0400
commite7dbdc02ac443bd8e691d1c2f8b722ec52749751 (patch)
treefa6adf567b6f384d83d50965ab39e6208a10eb36
parent35b40e007e28d7b4c041c7f6ed6cf9b6ad68c6fc (diff)
downloadaur-e7dbdc02ac443bd8e691d1c2f8b722ec52749751.tar.gz
Add Missing Optional Dependencies For Bundled Anki Client
I tried running the bundled anki client on my arch setup again (I normally use a windows and android client) and found that it wasn't working unless I installed these dependencies.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 11 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eaea7cc020ab..e5d2f5952c26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,11 +7,16 @@ pkgbase = anki-sync-server-git
arch = any
license = GPL
makedepends = portaudio
+ makedepends = git
depends = python
depends = python-pip
- depends = git
optdepends = python-pyqt5: dependency of bundled anki client
optdepends = python-pyqtwebengine: dependency of bundled anki client
+ optdepends = python-decorator: dependency of bundled anki client
+ optdepends = python-beautifulsoup4: dependency of bundled anki client
+ optdepends = python-markdown: dependency of bundled anki client
+ optdepends = python-requests: dependency of bundled anki client
+ optdepends = python-send2trash: dependency of bundled anki client
optdepends = libvpx>=1.8.0-1: dependency of bundled anki client
optdepends = double-conversion>=3.1.4-1: dependency of bundled anki client
optdepends = qt5-base>=5.12.2-1.1: dependency of bundled anki client
diff --git a/PKGBUILD b/PKGBUILD
index d14988946e8b..047971947f23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,11 @@ depends=('python' 'python-pip')
makedepends=('portaudio' 'git')
optdepends=('python-pyqt5: dependency of bundled anki client'
'python-pyqtwebengine: dependency of bundled anki client'
+'python-decorator: dependency of bundled anki client'
+'python-beautifulsoup4: dependency of bundled anki client'
+'python-markdown: dependency of bundled anki client'
+'python-requests: dependency of bundled anki client'
+'python-send2trash: dependency of bundled anki client'
'libvpx>=1.8.0-1: dependency of bundled anki client'
'double-conversion>=3.1.4-1: dependency of bundled anki client'
'qt5-base>=5.12.2-1.1: dependency of bundled anki client'