summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeraphJACK2022-08-08 23:41:59 +0800
committerSeraphJACK2022-08-08 23:43:25 +0800
commit1abfc36c66b5767d3a3ddab6e8f0dab985debdbc (patch)
treeeddf1d8f2823e1eead30b9eebd358afadc78c84b
downloadaur-1abfc36c66b5767d3a3ddab6e8f0dab985debdbc.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--annix3
-rw-r--r--annix.desktop10
-rw-r--r--annix.pngbin0 -> 10749 bytes
5 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21ea8c362e2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = annix-bin
+ pkgdesc = Music player for Project Anni. (Binary version)
+ pkgver = nightly
+ pkgrel = 1
+ url = https://github.com/ProjectAnni/annix
+ arch = x86_64
+ license = Apache
+ provides = annix
+ conflicts = annix
+ source = annix-nightly.zip::https://github.com/ProjectAnni/annix/releases/download/nightly/annix-linux64.zip
+ source = annix
+ source = annix.png
+ source = annix.desktop
+ sha256sums = 2a6be633760e701b36930de08062079d15607681fbec5b3d059b10905fe16784
+ sha256sums = bf17ec8adc0bf109d26231e47f339f493b5ff3d9d1724e399b9ebe1ca222df6e
+ sha256sums = 45d6cbfb1a232910c8c725b4242458e96058dd8c6d3eb7e1511b56909e1faaa1
+ sha256sums = e333918cd90c719ba39cd8d4e8d659c90237ca22fa5633829c99f4d5b6f4c2d7
+
+pkgname = annix-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52ca1ea87c89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Seraph_JACK <seraphjack@outlook.com>
+pkgname=annix-bin
+pkgver=nightly
+pkgrel=1
+pkgdesc="Music player for Project Anni. (Binary version)"
+arch=('x86_64')
+url="https://github.com/ProjectAnni/annix"
+license=('Apache')
+provides=("annix")
+conflicts=("annix")
+
+source=(annix-${pkgver}.zip::https://github.com/ProjectAnni/annix/releases/download/nightly/annix-linux64.zip
+ annix
+ annix.png
+ annix.desktop)
+
+sha256sums=('2a6be633760e701b36930de08062079d15607681fbec5b3d059b10905fe16784'
+ 'bf17ec8adc0bf109d26231e47f339f493b5ff3d9d1724e399b9ebe1ca222df6e'
+ '45d6cbfb1a232910c8c725b4242458e96058dd8c6d3eb7e1511b56909e1faaa1'
+ 'e333918cd90c719ba39cd8d4e8d659c90237ca22fa5633829c99f4d5b6f4c2d7')
+
+package() {
+ # Libraries
+ mkdir -p "${pkgdir}/usr/lib/annix"
+ cp -r "${srcdir}/bundle" "${pkgdir}/usr/lib/annix/"
+
+ # Binaries
+ install -D -m755 "${srcdir}/annix" "${pkgdir}/usr/bin/annix"
+
+ # Desktop launcher with icon
+ install -Dm644 "${srcdir}/annix.desktop" "${pkgdir}/usr/share/applications/annix.desktop"
+ install -Dm644 "${srcdir}/annix.png" "${pkgdir}/usr/share/pixmaps/annix.png"
+}
diff --git a/annix b/annix
new file mode 100644
index 000000000000..b9c237ca5e9c
--- /dev/null
+++ b/annix
@@ -0,0 +1,3 @@
+#!/bin/sh
+#LD_LIBRARY_PATH=/usr/lib/annix exec /usr/lib/annix/annix --bundle=/usr/share/annix/bundle "$@"
+exec /usr/lib/annix/bundle/annix "$@"
diff --git a/annix.desktop b/annix.desktop
new file mode 100644
index 000000000000..317c555db5b1
--- /dev/null
+++ b/annix.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Annix
+GenericName=Annix
+Comment=Music player for Project Anni
+Exec=/usr/bin/annix %F
+Icon=/usr/share/pixmaps/annix.png
+Terminal=false
+Type=Application
+Categories=AudioVideo;Player;
+Keywords=Music;MPD;
diff --git a/annix.png b/annix.png
new file mode 100644
index 000000000000..3ba205932000
--- /dev/null
+++ b/annix.png
Binary files differ