summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Ser2020-02-14 12:47:05 +0100
committerSimon Ser2020-02-14 12:47:05 +0100
commit28cbbc8afc52018c46863ccd82854e11c5b0b83b (patch)
tree0b68dd65ea567f3d88874dfec39fd16cf88d786d
downloadaur-annotatesh-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6470f84d6512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = annotatesh-git
+ pkgdesc = Generate sr.ht annotation graphs for POSIX shell scripts
+ pkgver = r6.002787d69543
+ pkgrel = 1
+ url = https://git.sr.ht/~emersion/annotatesh
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ depends = mrsh
+ depends = json-c
+ provides = annotatesh
+ conflicts = annotatesh
+ source = annotatesh::git+https://git.sr.ht/~emersion/annotatesh
+ sha1sums = SKIP
+
+pkgname = annotatesh-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..965ee68d9e28
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
+annotatesh/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a858aeb0182c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Simon Ser
+pkgname=annotatesh-git
+_pkgname=annotatesh
+pkgver=r6.002787d69543
+pkgrel=1
+license=('MIT')
+pkgdesc='Generate sr.ht annotation graphs for POSIX shell scripts'
+makedepends=("meson" "git")
+depends=("mrsh" "json-c")
+arch=("x86_64")
+url='https://git.sr.ht/~emersion/annotatesh'
+source=("${pkgname%-*}::git+https://git.sr.ht/~emersion/annotatesh")
+sha1sums=('SKIP')
+provides=('annotatesh')
+conflicts=('annotatesh')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ meson --prefix=/usr build/
+ ninja -C build/
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir/" ninja -C build/ install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"${pkgname%-*}"/LICENSE
+}