summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchisman Panigrahi2023-05-06 18:21:01 -0400
committerArchisman Panigrahi2023-05-06 18:21:01 -0400
commitdab9f7df3d4bc46374acf6b7aad4e9315018e35b (patch)
tree05d72e51e33b07056b7ac843aebf1e330d45bad2
parent608c74b28e1b31931b323b5bce65609da154e59e (diff)
downloadaur-dab9f7df3d4bc46374acf6b7aad4e9315018e35b.tar.gz
create symlink at /usr/bin/annotator and removed redundant dependencies gtk3 and libgee
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be9f28cf3623..d5484244133a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = annotator
pkgdesc = Image annotation for Elementary OS
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/phase1geo/Annotator
arch = aarch64
arch = armv6h
@@ -12,10 +12,8 @@ pkgbase = annotator
makedepends = git
makedepends = meson
makedepends = vala
- depends = gtk3
depends = libxml2
depends = libhandy
- depends = libgee
depends = granite
provides = Annotator
source = https://github.com/phase1geo/Annotator/archive/refs/tags/1.2.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 899301fe5bfe..5baf795f9a02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname="annotator"
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Image annotation for Elementary OS"
url="https://github.com/phase1geo/Annotator"
license=(" GPL3")
arch=('aarch64' 'armv6h' 'armv7h' 'i686' 'x86_64')
-depends=('gtk3' 'libxml2' 'libhandy' 'libgee' 'granite')
+depends=('libxml2' 'libhandy' 'granite')
makedepends=('git' 'meson' 'vala')
provides=("Annotator")
source=("https://github.com/phase1geo/Annotator/archive/refs/tags/${pkgver}.tar.gz")
@@ -23,5 +23,6 @@ build() {
package() {
cd "${srcdir}/Annotator-${pkgver}"
DESTDIR="${pkgdir}" ninja -C build install
+ ln -sv com.github.phase1geo.annotator "$pkgdir/usr/bin/annotator"
}