summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-11-06 13:03:26 -0600
committerMark Wagie2021-11-06 13:03:26 -0600
commitb5c472ccfab073ba1e43e650f9df51ffdc8ba384 (patch)
tree721e3a9f8c23031bdd361069a0a645dfdf0b0354
parentfcab9ceb9e2235240ff9c3e242cbe94bf4465a95 (diff)
downloadaur-b5c472ccfab073ba1e43e650f9df51ffdc8ba384.tar.gz
0.0.36
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD57
-rw-r--r--setup.patch27
4 files changed, 90 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32154419822f..45192ac9b84a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,24 @@
pkgbase = anoise
pkgdesc = Ambient Noise Player. Relax or concentrate with a noise
- pkgver = 0.0.29
- pkgrel = 1
- url = https://code.launchpad.net/anoise
+ pkgver = 0.0.36
+ pkgrel = 2
+ url = https://costales.github.io/projects/anoise
arch = any
license = GPL3
+ makedepends = python-distutils-extra
+ depends = gst-python
+ depends = webkit2gtk
depends = anoise-media
- depends = python-distutils-extra
- depends = gstreamer0.10
- depends = gstreamer0.10-python
- source = https://launchpad.net/~costales/+archive/ubuntu/anoise/+files/anoise_0.0.29_all.deb
- sha256sums = SKIP
+ optdepends = anoise-community-extension1: Sounds and icons from the users
+ optdepends = anoise-community-extension2: Sounds and icons from the users
+ optdepends = anoise-community-extension3: Sounds and icons from the users
+ optdepends = anoise-community-extension4: Sounds and icons from the users
+ optdepends = anoise-community-extension5: Sounds and icons from the users
+ optdepends = anoise-gui: GUI for anoise
+ optdepends = libappindicator-gtk3: tray icon
+ source = https://launchpad.net/~costales/+archive/ubuntu/anoise/+sourcefiles/anoise/0.0.36/anoise_0.0.36.tar.gz
+ source = setup.patch
+ sha256sums = cd6e2e1e8691b950c503b4319f7f9ecf6e66c745e5194724be0c3e026e9dd3ac
+ sha256sums = e561b2513e791c29d097e7eea7c83f9bbe3d993ead398e7dd0352bbb55ce451a
pkgname = anoise
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6d26664c68d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!setup.patch
diff --git a/PKGBUILD b/PKGBUILD
index f8d3a44bf719..36abfa0e532d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,50 @@
-#Maintainer: Alexander Adler <alexadler1@protonmail.com>
-#Contributor: Yan Burdonsky <psyrccio@gmail.com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Alexander Adler <alexadler1@protonmail.com>
+# Contributor: Yan Burdonsky <psyrccio@gmail.com>
+
+# Copy your OGG|MP3|WAV noises into ~/ANoise or ~/.ANoise
+
pkgname=anoise
-pkgver=0.0.29
-pkgrel=1
+pkgver=0.0.36
+pkgrel=2
pkgdesc="Ambient Noise Player. Relax or concentrate with a noise"
arch=('any')
+url="https://costales.github.io/projects/anoise"
license=('GPL3')
-url="https://code.launchpad.net/anoise"
-options=()
-conflicts=()
-makedeps=('bison' 'flex')
-depends=('anoise-media' 'python-distutils-extra' 'gstreamer0.10' 'gstreamer0.10-python')
-optdepends=()
-source=("https://launchpad.net/~costales/+archive/ubuntu/anoise/+files/${pkgname}_${pkgver}_all.deb")
-sha256sums=('SKIP')
+depends=('gst-python' 'webkit2gtk' 'anoise-media')
+makedepends=('python-distutils-extra')
+optdepends=('anoise-community-extension1: Sounds and icons from the users'
+ 'anoise-community-extension2: Sounds and icons from the users'
+ 'anoise-community-extension3: Sounds and icons from the users'
+ 'anoise-community-extension4: Sounds and icons from the users'
+ 'anoise-community-extension5: Sounds and icons from the users'
+ 'anoise-gui: GUI for anoise'
+ 'libappindicator-gtk3: tray icon')
+source=("https://launchpad.net/~costales/+archive/ubuntu/$pkgname/+sourcefiles/$pkgname/$pkgver/${pkgname}_${pkgver}.tar.gz"
+ 'setup.patch')
+sha256sums=('cd6e2e1e8691b950c503b4319f7f9ecf6e66c745e5194724be0c3e026e9dd3ac'
+ 'e561b2513e791c29d097e7eea7c83f9bbe3d993ead398e7dd0352bbb55ce451a')
+
+prepare() {
+ cd "$srcdir/$pkgname "
+ patch --forward --strip=1 --input="$srcdir/setup.patch"
+}
build() {
- cd "${srcdir}"
+ cd "$srcdir/$pkgname "
+ python setup.py build
}
package() {
- cd "${srcdir}"
+ cd "$srcdir/$pkgname "
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # This file is included in anoise-gui
+ rm "$pkgdir/usr/share/$pkgname/$pkgname.ui"
- ar x "${pkgname}_${pkgver}_all.deb" > /dev/null
- tar -xJf data.tar.xz -C "${pkgdir}"
+ # Files setup.py does not install
+ cp -r locale "$pkgdir/usr/share/locale"
- install -d -m755 "${pkgdir}/usr/"
- rm ${pkgdir}/usr/share/anoise/preferences.py
- cp ../preferences.py ${pkgdir}/usr/share/anoise/
+ install -Dm644 "build/share/applications/$pkgname.desktop" -t \
+ "$pkgdir/usr/share/applications"
}
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..fdaa874a046b
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,27 @@
+diff --unified --recursive --text anoise.orig/setup.py anoise.new/setup.py
+--- anoise.orig/setup.py 2020-04-21 17:47:31.000000000 -0600
++++ anoise.new/setup.py 2020-08-05 13:59:17.041960805 -0600
+@@ -18,7 +18,13 @@
+ # for more information.
+
+
+-import os, sys, DistUtilsExtra.auto
++import os, sys, glob, DistUtilsExtra.auto
++
++# Create data files
++data = [ ('/usr/share/anoise', glob.glob('anoise/*')),
++ ('/usr/share/icons/hicolor/scalable/apps', glob.glob('icons/hicolor/scalable/apps/*.svg')),
++ ('/usr/share/icons/hicolor/48x48/apps', glob.glob('icons/hicolor/48x48/apps/*.png')),
++ ('/usr/share/icons/hicolor/16x16/apps', glob.glob('icons/hicolor/16x16/apps/*.png'))]
+
+ # Setup stage
+ DistUtilsExtra.auto.setup(
+@@ -28,6 +34,7 @@
+ author = "Marcos Alvarez Costales https://costales.github.io/",
+ author_email = "marcos.costales@gmail.com",
+ url = "https://costales.github.io/projects/anoise/",
+- license = "GPL3"
++ license = "GPL3",
++ data_files = data
+ )
+