summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Förderer2015-06-09 06:44:37 +0200
committerDominik Förderer2015-06-09 06:44:37 +0200
commitb2605ff07f869279f3c0bbd8977aae6ae2541cfa (patch)
tree38a99538471d2d679fc580dd578d70e83ac94687
downloadaur-b2605ff07f869279f3c0bbd8977aae6ae2541cfa.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
-rwxr-xr-xpostinst3
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32e01d4e4254
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Tue Apr 7 16:03:25 UTC 2015
+pkgbase = anoise-community-extension1
+ pkgdesc = Ambient Noise Community Library. Sounds and icons from the users
+ pkgver = 0.0.1
+ pkgrel = 0
+ url = https://code.launchpad.net/anoise
+ install = postinst
+ arch = any
+ license = GPL3
+ depends = anoise
+ depends = python-distutils-extra
+ depends = gstreamer0.10
+ depends = gstreamer0.10-python
+ source = https://launchpad.net/~costales/+archive/ubuntu/anoise/+files/anoise-community-extension1_0.0.1_all.deb
+ md5sums = 1a14263778ea070558f440fab8066a2d
+
+pkgname = anoise-community-extension1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9205eaa0aa02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: agnotek <agnostic[dot]sn[at]gmail[dot]com>
+
+pkgname=anoise-community-extension1
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="Ambient Noise Community Library. Sounds and icons from the users"
+arch=('any')
+license=('GPL3')
+url="https://code.launchpad.net/anoise"
+install=postinst
+options=()
+conflicts=()
+depends=('anoise' 'python-distutils-extra' 'gstreamer0.10' 'gstreamer0.10-python')
+optdepends=()
+source=("https://launchpad.net/~costales/+archive/ubuntu/anoise/+files/${pkgname}_${pkgver}_all.deb")
+md5sums=('1a14263778ea070558f440fab8066a2d')
+
+package() {
+ cd "${srcdir}"
+
+ ar x "${pkgname}_${pkgver}_all.deb" > /dev/null
+ tar -xJf data.tar.xz -C "${pkgdir}"
+
+ install -d -m755 "${pkgdir}/usr/"
+
+}
+
diff --git a/postinst b/postinst
new file mode 100755
index 000000000000..aa2813997b32
--- /dev/null
+++ b/postinst
@@ -0,0 +1,3 @@
+#!/bin/sh
+set -e
+