summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio2015-06-10 17:10:18 +0200
committerFabio2015-06-10 17:10:18 +0200
commit340540dc7b445cd6c2636a532a6756074be96c42 (patch)
treeb9e3bbef3ebd032e874e4397c15a906c200070b6
downloadaur-340540dc7b445cd6c2636a532a6756074be96c42.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--license.txt24
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dc2d0b80e64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = anonip
+ pkgdesc = An ip address anonymizer.
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://www.privacyfoundation.ch/en/services/anonip.html
+ arch = any
+ license = BSD
+ depends = python2
+ source = https://www.privacyfoundation.ch/assets/files/anonip-0.5.tar.gz
+ source = license.txt
+ md5sums = d2a8381014751968819753ae2899860e
+ md5sums = 7edc561924bc592f10c65fa782bf7fbf
+
+pkgname = anonip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..839ca2491503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Swiss Privacy Foundation <anonip[at]privacyfoundation[dot]ch>
+pkgname=anonip
+pkgver=0.5
+pkgrel=1
+pkgdesc="An ip address anonymizer."
+arch=('any')
+url="https://www.privacyfoundation.ch/en/services/$pkgname.html"
+license=('BSD')
+depends=('python2')
+source=("https://www.privacyfoundation.ch/assets/files/$pkgname-$pkgver.tar.gz"
+ "license.txt")
+md5sums=('d2a8381014751968819753ae2899860e'
+ '7edc561924bc592f10c65fa782bf7fbf')
+
+package() {
+ cd "$srcdir"
+ install -d $pkgdir/usr/share/$pkgname
+ install -d $pkgdir/usr/share/licenses/$pkgname
+ install -d $pkgdir/usr/bin
+ install -m644 -t $pkgdir/usr/share/$pkgname/ README README_DE
+ install -m644 -t $pkgdir/usr/share/licenses/$pkgname license.txt
+ install -m755 $pkgname.py $pkgdir/usr/share/$pkgname/
+ ln -sf /usr/share/$pkgname/$pkgname.py $pkgdir/usr/bin/$pkgname
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..3ffd2d512c86
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,24 @@
+Copyright (c) 2013, 2014, Swiss Privacy Foundation
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the Swiss Privacy Foundation nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE SWISS PRIVACY FOUNDATION BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.