summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Rämi2019-07-28 13:31:31 +0200
committerFabio Rämi2019-07-28 13:31:31 +0200
commitbd3af97eabd291bfb11b7ad54f7c9df569e49e06 (patch)
treeb16d88f76622c7aafc3327c8309bff8b2a8a9cd8
parent340540dc7b445cd6c2636a532a6756074be96c42 (diff)
downloadaur-bd3af97eabd291bfb11b7ad54f7c9df569e49e06.tar.gz
update to v1.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD28
-rw-r--r--license.txt24
4 files changed, 48 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dc2d0b80e64..3184b4ae58ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = anonip
- pkgdesc = An ip address anonymizer.
- pkgver = 0.5
+ pkgdesc = Anonip is a tool to anonymize IP-addresses in log-files.
+ pkgver = 1.0.0
pkgrel = 1
- url = https://www.privacyfoundation.ch/en/services/anonip.html
+ url = https://github.com/DigitaleGesellschaft/Anonip
arch = any
license = BSD
- depends = python2
- source = https://www.privacyfoundation.ch/assets/files/anonip-0.5.tar.gz
- source = license.txt
- md5sums = d2a8381014751968819753ae2899860e
- md5sums = 7edc561924bc592f10c65fa782bf7fbf
+ depends = python
+ source = https://github.com/DigitaleGesellschaft/Anonip/archive/v1.0.0.tar.gz
+ source = LICENSE
+ sha256sums = ee34c76817d32aa97cf96451a9005948bddbdaaa0dc93b3583d1fa1ace61d454
+ sha256sums = bfb9e7ead9baa5171df9f9fe24e93a917cd9903cc9e0bcc3cdf948f33bbb89ad
pkgname = anonip
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..433966189d49
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 2013 - 2016, Swiss Privacy Foundation
+ 2016 - 2019, Digitale Gesellschaft
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of Digitale Gesellschaft nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 839ca2491503..87e4c199a0b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
# Maintainer: Swiss Privacy Foundation <anonip[at]privacyfoundation[dot]ch>
+
+_pkgname=Anonip
pkgname=anonip
-pkgver=0.5
+pkgver=1.0.0
pkgrel=1
-pkgdesc="An ip address anonymizer."
+pkgdesc="Anonip is a tool to anonymize IP-addresses in log-files."
arch=('any')
-url="https://www.privacyfoundation.ch/en/services/$pkgname.html"
+url="https://github.com/DigitaleGesellschaft/Anonip"
license=('BSD')
-depends=('python2')
-source=("https://www.privacyfoundation.ch/assets/files/$pkgname-$pkgver.tar.gz"
- "license.txt")
-md5sums=('d2a8381014751968819753ae2899860e'
- '7edc561924bc592f10c65fa782bf7fbf')
+depends=('python')
+source=("https://github.com/DigitaleGesellschaft/${_pkgname}/archive/v${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=('ee34c76817d32aa97cf96451a9005948bddbdaaa0dc93b3583d1fa1ace61d454'
+ 'bfb9e7ead9baa5171df9f9fe24e93a917cd9903cc9e0bcc3cdf948f33bbb89ad')
package() {
- cd "$srcdir"
- install -d $pkgdir/usr/share/$pkgname
install -d $pkgdir/usr/share/licenses/$pkgname
- install -d $pkgdir/usr/bin
- install -m644 -t $pkgdir/usr/share/$pkgname/ README README_DE
- install -m644 -t $pkgdir/usr/share/licenses/$pkgname license.txt
- install -m755 $pkgname.py $pkgdir/usr/share/$pkgname/
- ln -sf /usr/share/$pkgname/$pkgname.py $pkgdir/usr/bin/$pkgname
+ install -m644 -t $pkgdir/usr/share/licenses/$pkgname LICENSE
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}
diff --git a/license.txt b/license.txt
deleted file mode 100644
index 3ffd2d512c86..000000000000
--- a/license.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-Copyright (c) 2013, 2014, Swiss Privacy Foundation
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
- * Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
- * Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
- * Neither the name of the Swiss Privacy Foundation nor the
- names of its contributors may be used to endorse or promote products
- derived from this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE SWISS PRIVACY FOUNDATION BE LIABLE FOR ANY
-DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.