summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWirlaburla2024-04-09 21:29:15 -0500
committerWirlaburla2024-04-09 21:29:15 -0500
commited5ba554f1721f55166607bb48f515c5a5351e47 (patch)
treeb53310282313033fff3804295c863f340901bdb0
downloadaur-ed5ba554f1721f55166607bb48f515c5a5351e47.tar.gz
initial aur commit
-rw-r--r--PKGBUILD17
-rwxr-xr-xanope.service8
2 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ed231a66ba2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Nick G. <wirlaburla@worlio.com>
+
+_pkgname=anope
+pkgname=${_pkgname}-dinit
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A set of IRC Services designed for flexibility and ease of use (dinit)"
+arch=('any')
+source=("${_pkgname}.service")
+depends=("${_pkgname}")
+sha256sums=(
+ '63f8b05c4095e11d9c6c2601c2cd972dbf70c93ad44fdd481c576335980b9f8b'
+)
+
+package() {
+ install -Dm644 "${_pkgname}.service" "$pkgdir/etc/dinit.d/${_pkgname}"
+}
diff --git a/anope.service b/anope.service
new file mode 100755
index 000000000000..c45c145d8e09
--- /dev/null
+++ b/anope.service
@@ -0,0 +1,8 @@
+type = process
+pid-file = /run/anope/anope.pid
+command = /usr/bin/services --confdir=/etc/anope --dbdir=/var/lib/anope --localedir=/usr/lib/anope/locale --logdir=/var/log/anope --modulesdir=/usr/lib/anope --nofork
+smooth-recovery = true
+logfile = /var/log/dinit/anope.log
+run-as = anope
+after = network
+depends-on = network