summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane2019-07-11 02:22:56 +0800
committerShane2019-07-11 02:22:56 +0800
commitdb4bd90ff536f2d054deb6114a2bcca318426653 (patch)
tree29ee93dd138762052adaf29db91fcbd61e9139b9
parenteb9e942c3c9816a5c9270b5ab171c19d587947d1 (diff)
downloadaur-db4bd90ff536f2d054deb6114a2bcca318426653.tar.gz
添加LICENSE
-rw-r--r--.SRCINFO7
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD20
3 files changed, 36 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be2eafcd6517..493ec9f0f33b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,6 @@ pkgbase = another-redis-desktop-manager
url = https://github.com/qishibo/AnotherRedisDesktopManager
arch = x86_64
license = MIT
- depends = aria2
depends = libappindicator-sharp
depends = libappindicator-gtk3
depends = libappindicator-gtk2
@@ -18,9 +17,11 @@ pkgbase = another-redis-desktop-manager
source = https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.2.4/Another.Redis.Desktop.Manager.1.2.4.AppImage
source = another-redis-desktop-manager.desktop
source = another-redis-desktop-manager.png
+ source = LICENSE
md5sums = 9818915d396b59af1037b17fd1c3460f
- md5sums = SKIP
- md5sums = SKIP
+ md5sums = 11ac6e7e9d578a9ad0b548c3fc9a2527
+ md5sums = 3f7c15e66be6ffd8b70fbb50882fc0dd
+ md5sums = 74fd786ee05276f7550f94e8ed1bf495
pkgname = another-redis-desktop-manager
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e6210fb65459
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) qii404.me
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 72760490cea2..3e58a8b5cb49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Shane Lyx <shanelyx@outlook.com>
+# Maintainer: Shane Lyx <shanelyx at outlook dot com>
pkgname=another-redis-desktop-manager
pkgver=1.2.4
pkgrel=1
@@ -6,22 +6,20 @@ pkgdesc="Another Redis Desktop Manager"
arch=("x86_64")
url="https://github.com/qishibo/AnotherRedisDesktopManager"
license=('MIT')
-depends=('aria2' 'libappindicator-sharp' 'libappindicator-gtk3' 'libappindicator-gtk2' 'gconf' 'libindicator-gtk3' 'libindicator-gtk2'
+depends=('libappindicator-sharp' 'libappindicator-gtk3' 'libappindicator-gtk2' 'gconf' 'libindicator-gtk3' 'libindicator-gtk2'
'libnotify' 'libxss' 'libxtst')
-DLAGENTS=('https::/usr/bin/aria2c -x 5 -c --disable-ipv6=true --check-certificate=false -o %o %u')
-
source=(
"https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.2.4/Another.Redis.Desktop.Manager.1.2.4.AppImage"
"another-redis-desktop-manager.desktop"
"another-redis-desktop-manager.png"
+ "LICENSE"
)
-md5sums=(
- "9818915d396b59af1037b17fd1c3460f"
- "SKIP"
- "SKIP"
-)
+md5sums=('9818915d396b59af1037b17fd1c3460f'
+ '11ac6e7e9d578a9ad0b548c3fc9a2527'
+ '3f7c15e66be6ffd8b70fbb50882fc0dd'
+ '74fd786ee05276f7550f94e8ed1bf495')
package(){
cd ${srcdir}
@@ -35,6 +33,10 @@ package(){
# icon
mkdir -p ${pkgdir}/usr/share/icons/hicolor/512x512/apps
install -Dm644 another-redis-desktop-manager.png ${pkgdir}/usr/share/icons/hicolor/512x512/apps/
+
+ #license
+ mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/
}