summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-02 09:45:37 +0800
committerzxp198210052024-02-02 09:45:37 +0800
commit8f0dfaac18caeb5f1e44b504ad280773b7084e76 (patch)
treea85854c3069b92e5daf86f674e027ba54a1a2f20
parentfa2b05ee1c7abfdbf60153e5a5c521566c561e2c (diff)
downloadaur-8f0dfaac18caeb5f1e44b504ad280773b7084e76.tar.gz
update to 1.6.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--another-redis-desktop-manager.sh9
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fef297d3bb7..b61fc9ec09ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = another-redis-desktop-manager-bin
pkgdesc = A faster, better and more stable Redis desktop manager [GUI client]
- pkgver = 1.6.1
- pkgrel = 2
+ pkgver = 1.6.2
+ pkgrel = 1
url = https://github.com/qishibo/AnotherRedisDesktopManager
arch = x86_64
license = MIT
@@ -10,13 +10,13 @@ pkgbase = another-redis-desktop-manager-bin
depends = gtk2
depends = dbus-glib
depends = java-runtime
- provides = another-redis-desktop-manager=1.6.1
+ provides = another-redis-desktop-manager=1.6.2
conflicts = another-redis-desktop-manager
- source = another-redis-desktop-manager-1.6.1.AppImage::https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.6.1/Another-Redis-Desktop-Manager.1.6.1.AppImage
- source = LICENSE-1.6.1::https://raw.githubusercontent.com/qishibo/AnotherRedisDesktopManager/v1.6.1/LICENSE
+ source = another-redis-desktop-manager-1.6.2.AppImage::https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.6.2/Another-Redis-Desktop-Manager.1.6.2.AppImage
+ source = LICENSE-1.6.2::https://raw.githubusercontent.com/qishibo/AnotherRedisDesktopManager/v1.6.2/LICENSE
source = another-redis-desktop-manager.sh
- sha256sums = bf63908cef742f46b7d4c6b5a91593a373f88accc4f00ddb7740c527ccbfc2a3
+ sha256sums = b2387ec727932c597d2748c3b2ab366c16c9651c2d6ff5810518c6f117109458
sha256sums = 49e1afe88ff863df075233daa348d313c1f77110de7d89794a6a9ae45b38c1b3
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = another-redis-desktop-manager-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3512fc4baa8f..6e87ad808e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=another-redis-desktop-manager-bin
_pkgname=Another-Redis-Desktop-Manager
-pkgver=1.6.1
+pkgver=1.6.2
_electronversion=12
-pkgrel=2
+pkgrel=1
pkgdesc="A faster, better and more stable Redis desktop manager [GUI client]"
arch=('x86_64')
url="https://github.com/qishibo/AnotherRedisDesktopManager"
@@ -22,13 +22,13 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/qishibo/AnotherRedisDesktopManager/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('bf63908cef742f46b7d4c6b5a91593a373f88accc4f00ddb7740c527ccbfc2a3'
+sha256sums=('b2387ec727932c597d2748c3b2ab366c16c9651c2d6ff5810518c6f117109458'
'49e1afe88ff863df075233daa348d313c1f77110de7d89794a6a9ae45b38c1b3'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/another-redis-desktop-manager.sh b/another-redis-desktop-manager.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/another-redis-desktop-manager.sh
+++ b/another-redis-desktop-manager.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file