summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-26 18:31:15 +0800
committerzxp198210052023-10-26 18:31:15 +0800
commit9c250ef56e0b52548785307b3d904b49c2eb8645 (patch)
treee303c6e3a8cf6e383117bb038cf071742fe82f7d
downloadaur-9c250ef56e0b52548785307b3d904b49c2eb8645.tar.gz
update to 1.6.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--another-redis-desktop-manager.sh11
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fff7466409c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = another-redis-desktop-manager-bin
+ pkgdesc = A faster, better and more stable Redis desktop manager [GUI client]
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/qishibo/AnotherRedisDesktopManager
+ arch = x86_64
+ license = MIT
+ makedepends = asar
+ depends = bash
+ depends = electron12
+ provides = another-redis-desktop-manager=1.6.1
+ conflicts = another-redis-desktop-manager
+ source = another-redis-desktop-manager-1.6.1.AppImage::https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.6.1/Another-Redis-Desktop-Manager.1.6.1.AppImage
+ source = LICENSE::https://raw.githubusercontent.com/qishibo/AnotherRedisDesktopManager/v1.6.1/LICENSE
+ source = another-redis-desktop-manager.sh
+ sha256sums = bf63908cef742f46b7d4c6b5a91593a373f88accc4f00ddb7740c527ccbfc2a3
+ sha256sums = 49e1afe88ff863df075233daa348d313c1f77110de7d89794a6a9ae45b38c1b3
+ sha256sums = 06be6107e888b7801a147ae43f7b2ed80ed55492f72f7e940d831194400da6c3
+
+pkgname = another-redis-desktop-manager-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88d4c5203177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=another-redis-desktop-manager-bin
+_pkgname=Another-Redis-Desktop-Manager
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="A faster, better and more stable Redis desktop manager [GUI client]"
+arch=('x86_64')
+url="https://github.com/qishibo/AnotherRedisDesktopManager"
+license=('MIT')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}=${pkgver}")
+depends=(
+ 'bash'
+ 'electron12'
+)
+makedepends=(
+ 'asar'
+)
+source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}.${pkgver}.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/qishibo/AnotherRedisDesktopManager/v${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh")
+sha256sums=('bf63908cef742f46b7d4c6b5a91593a373f88accc4f00ddb7740c527ccbfc2a3'
+ '49e1afe88ff863df075233daa348d313c1f77110de7d89794a6a9ae45b38c1b3'
+ '06be6107e888b7801a147ae43f7b2ed80ed55492f72f7e940d831194400da6c3')
+build() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ asar e "${srcdir}/squashfs-root/resources/app.asar" "${srcdir}/app.asar.unpacked"
+ cp "${srcdir}/squashfs-root/resources/app-update.yml" "${srcdir}/app.asar.unpacked/dev-app-update.yml"
+ asar p "${srcdir}/app.asar.unpacked" "${srcdir}/app.asar"
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/app.asar.unpacked" "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/usr/lib"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/another-redis-desktop-manager.sh b/another-redis-desktop-manager.sh
new file mode 100644
index 000000000000..98bd7832279c
--- /dev/null
+++ b/another-redis-desktop-manager.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron12
+APPDIR="/usr/lib/another-redis-desktop-manager"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file