summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-08-21 09:54:10 -0400
committerMario Finelli2021-08-21 09:54:10 -0400
commita5dcdb106e6189d1aeb4c4185f95978b6063c957 (patch)
tree180d2366dd91022aa473f7ebfb9b19f77789f56d
downloadaur-a5dcdb106e6189d1aeb4c4185f95978b6063c957.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c6b80f733bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ansible-aur
+ pkgdesc = Ansible module to manage packages from the AUR
+ pkgver = 0.43
+ pkgrel = 1
+ url = https://github.com/kewlfft/ansible-aur
+ arch = any
+ license = GPL3
+ source = https://github.com/kewlfft/ansible-aur/archive/v0.43/ansible-aur-0.43.tar.gz
+ sha256sums = 485a3bc3b5e4ef4d42b6f65a9b74754935e64754d535cc6d44e4e11584927263
+
+pkgname = ansible-aur
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e8e28dd9c48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+# Contributor: pancho horrillo <pancho at pancho dot name>
+
+pkgname=ansible-aur
+pkgver=0.43
+pkgrel=1
+pkgdesc="Ansible module to manage packages from the AUR"
+arch=(any)
+url=https://github.com/kewlfft/ansible-aur
+license=(GPL3)
+source=("https://github.com/kewlfft/ansible-aur/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('485a3bc3b5e4ef4d42b6f65a9b74754935e64754d535cc6d44e4e11584927263')
+
+package() {
+ cd $pkgname-$pkgver
+
+ install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm0644 library/aur.py \
+ "$pkgdir/usr/share/ansible/plugins/modules/aur.py"
+}