summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2019-08-22 09:40:49 -0400
committerJameson Pugh2019-08-22 09:40:49 -0400
commitac86588bc6ffc153d416008dcdd55e29b65e1521 (patch)
tree615b071f5f6cc2b551ff426902c4fa4453790b82
downloadaur-ac86588bc6ffc153d416008dcdd55e29b65e1521.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..273e54eb92ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ansible-bundler
+ pkgdesc = Bundles Ansible playbooks and dependancies into a single binary.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/kriansa/ansible-bundler
+ arch = any
+ license = BSD
+ depends = ansible
+ source = https://github.com/kriansa/ansible-bundler/archive/v1.1.0.tar.gz
+ sha256sums = a6e52b3cfa12a59defcb7ba5aed0709bb131c534a43c3a25106855f8b056748e
+
+pkgname = ansible-bundler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d023078f62b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=ansible-bundler
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Bundles Ansible playbooks and dependancies into a single binary."
+arch=('any')
+url="https://github.com/kriansa/ansible-bundler"
+license=('BSD')
+depends=('ansible')
+source=("https://github.com/kriansa/ansible-bundler/archive/v${pkgver}.tar.gz")
+sha256sums=('a6e52b3cfa12a59defcb7ba5aed0709bb131c534a43c3a25106855f8b056748e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cp -r build/pkg/* "$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: