summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardar2023-11-07 13:17:46 +0000
committerAmin Vakil2023-11-07 17:06:48 +0330
commitb6f3d1ed24c857607f636ecfc36d8498286d4349 (patch)
tree0ca31e6f5da126ef5f56578bd7788493823cb758
parent860cbad86f14d0749c522a8e2294e1713e700ea3 (diff)
downloadaur-b6f3d1ed24c857607f636ecfc36d8498286d4349.tar.gz
fix: use build/install instead of setuptools
invoking setup.py directly is deprecated: https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75e22ccbec31..5c246a6a5d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,18 +8,17 @@ arch=('any')
url="https://github.com/fboender/ansible-cmdb"
license=('GPL3')
depends=('python' 'python-mako' 'python-pyyaml')
-makedepends=('python-setuptools' 'git')
+makedepends=('python-setuptools' 'git' 'python-build' 'python-installer' 'python-wheel')
# source=("${pkgname}-${pkgver}-${pkgrel}.tar.gz::${url}/archive/${pkgver}.tar.gz")
source=("git+https://github.com/gardar/ansible-cmdb.git#branch=fix-build")
sha256sums=('SKIP')
build() {
cd "$srcdir/${pkgname}"
- python setup.py build
+ python -m build
}
package() {
cd "$srcdir/${pkgname}"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}