summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Heusel2023-03-28 21:23:42 +0200
committerChristian Heusel2023-03-28 21:23:42 +0200
commitfbef1a0f1a32270df5935b0c84358e4d7b8a07e7 (patch)
tree32ad58abceb62f1be4955f498d36794453716ba8
parent86ad0ae9381d42a858704fa89e92ddcba1c526af (diff)
downloadaur-fbef1a0f1a32270df5935b0c84358e4d7b8a07e7.tar.gz
fix the executable bits for the plugin
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ea1ef57e48b..a59cdb6476a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ansible-gopass
pkgdesc = a ansible plugin to lookup passwords in the gopass password manager
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/christian-heusel/ansible-lookup-plugin-gopass
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 1c967414c906..fe3ee442cdfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ansible-gopass
_reponame=ansible-lookup-plugin-gopass
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='a ansible plugin to lookup passwords in the gopass password manager'
arch=('any')
url="https://github.com/christian-heusel/$_reponame"
@@ -13,5 +13,5 @@ sha256sums=('19186193bc731269303c45ec8ffde4c4386f36c8482fb64ae0cf113aee8b5d4f')
package() {
cd "$_reponame-$pkgver"
- install -D lookup_plugins/gopass.py "$pkgdir"/usr/share/ansible/plugins/lookup/$pkgname/gopass.py
+ install -Dm644 lookup_plugins/gopass.py "$pkgdir"/usr/share/ansible/plugins/lookup/$pkgname/gopass.py
}