summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjasle2020-10-14 22:12:12 +0200
committerjasle2020-10-14 22:12:12 +0200
commitde8d5a2dee83d99b7305f7394bf6e68264e604f6 (patch)
tree24a6acf22a0bca164ee94ded14549455ce51d2b0
downloadaur-de8d5a2dee83d99b7305f7394bf6e68264e604f6.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..083c1ce1801a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ansible-keepass-git
+ pkgdesc = Ansible plugin to fetch data from KeePass database file
+ pkgver = r11.1f0388e
+ pkgrel = 1
+ url = https://github.com/viczem/ansible-keepass
+ arch = any
+ license = MIT
+ depends = ansible
+ depends = python-pykeepass
+ provides = ansible-keepass
+ conflicts = ansible-keepass
+ source = git+https://github.com/viczem/ansible-keepass.git
+ sha256sums = SKIP
+
+pkgname = ansible-keepass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e6a28fe5309
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: jasle <jasle at riseup dot net>
+
+_pkgname='ansible-keepass'
+pkgname="${_pkgname}-git"
+pkgver=r11.1f0388e
+pkgrel=1
+pkgdesc='Ansible plugin to fetch data from KeePass database file'
+arch=('any')
+url='https://github.com/viczem/ansible-keepass'
+license=('MIT')
+depends=('ansible' 'python-pykeepass')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/viczem/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "${_pkgname}"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 keepass.py "$pkgdir/usr/share/ansible/plugins/modules/keepass.py"
+}