summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2018-05-22 13:05:04 -0400
committerJameson Pugh2018-05-22 13:05:04 -0400
commitf1ac449bb3eb15b9c774ce57d488d465251d8179 (patch)
tree25bab5957ff8bbe70d471ac22f5d8639b25f4f2d
downloadaur-f1ac449bb3eb15b9c774ce57d488d465251d8179.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cf122d7a449
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ansible-review
+ pkgdesc = Reviews Ansible playbooks, roles and inventory and suggests improvements.
+ pkgver = 0.13.4
+ pkgrel = 1
+ url = https://github.com/willthames/ansible-review
+ arch = any
+ license = MIT
+ makedepends = python2-nose
+ depends = ansible-lint
+ depends = python-yaml
+ depends = python-appdirs
+ depends = python-unidiff
+ depends = flake8
+ source = https://github.com/willthames/ansible-review/archive/v0.13.4.tar.gz
+ sha256sums = 8071e884a8e9f388eeb15b8c88ec915cc3ede89303fa937383c4918e5ceb5ef4
+
+pkgname = ansible-review
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2567c287ea4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=ansible-review
+pkgver=0.13.4
+pkgrel=1
+pkgdesc="Reviews Ansible playbooks, roles and inventory and suggests improvements."
+url="https://github.com/willthames/ansible-review"
+depends=('ansible-lint' 'python-yaml' 'python-appdirs' 'python-unidiff' 'flake8')
+makedepends=('python2-nose')
+license=('MIT')
+arch=('any')
+source=("https://github.com/willthames/ansible-review/archive/v${pkgver}.tar.gz")
+sha256sums=('8071e884a8e9f388eeb15b8c88ec915cc3ede89303fa937383c4918e5ceb5ef4')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ #python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: