summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeffrey Zhang2024-06-12 00:55:27 +0800
committerJeffrey Zhang2024-06-12 00:55:43 +0800
commit2458a7eb7735a9ee0e6c8d9d0a74886a0e89e755 (patch)
treeedab90dd9cd907bf9dce15444b3b1597389325d8
parent6b0bbcf37d07e588ecd5a449144aec73bef78ee8 (diff)
downloadaur-2458a7eb7735a9ee0e6c8d9d0a74886a0e89e755.tar.gz
bump to version 2.4.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be75cf4ec5e8..454c85f24705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = ansible-runner
pkgdesc = A tool and python library that helps when interfacing with Ansible directly
- pkgver = 2.3.5
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/ansible/ansible-runner
arch = any
license = Apache
makedepends = python-setuptools
makedepends = python-pbr
+ makedepends = git
+ makedepends = python-wheel
depends = python-psutil
depends = python-pexpect
depends = python-daemon
depends = python-yaml
depends = python-six
- source = https://files.pythonhosted.org/packages/e8/c7/c5f3fb32de173ff821554ead3deeeb8ac79b2874fc716341771fc53580da/ansible-runner-2.3.5.tar.gz
- sha256sums = cd9ddd5765870ea3c545b6cb47aaad5f04d9a30a628dd3fcdb4f367a28c22085
+ source = https://files.pythonhosted.org/packages/e0/b4/842698d5c17b3cae7948df4c812e01f4199dfb9f35b1c0bb51cf2fe5c246/ansible-runner-2.4.0.tar.gz
+ sha256sums = 82d02b2548830f37a53517b65c823c4af371069406c7d213b5c9041d45e0c5b6
pkgname = ansible-runner
diff --git a/PKGBUILD b/PKGBUILD
index 8d3d3334887e..dcd2bd4f5044 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeffrey Zhang <zhang.lei.fly#gmail.com>
pkgname=ansible-runner
-pkgver=2.3.5
+pkgver=2.4.0
pkgrel=1
pkgdesc="A tool and python library that helps when interfacing with Ansible directly"
arch=("any")
@@ -12,20 +12,20 @@ depends=("python-psutil"
"python-daemon"
"python-yaml"
"python-six")
-makedepends=('python-setuptools' 'python-pbr')
-source=("https://files.pythonhosted.org/packages/e8/c7/c5f3fb32de173ff821554ead3deeeb8ac79b2874fc716341771fc53580da/ansible-runner-${pkgver}.tar.gz")
-sha256sums=('cd9ddd5765870ea3c545b6cb47aaad5f04d9a30a628dd3fcdb4f367a28c22085')
+makedepends=('python-setuptools' 'python-pbr' 'git' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/e0/b4/842698d5c17b3cae7948df4c812e01f4199dfb9f35b1c0bb51cf2fe5c246/ansible-runner-${pkgver}.tar.gz")
+sha256sums=('82d02b2548830f37a53517b65c823c4af371069406c7d213b5c9041d45e0c5b6')
build() {
cd ${pkgname}-${pkgver}
- python setup.py build
+ python -m build
}
package() {
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
cd ${pkgname}-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m pip install --root="$pkgdir" .
rm -rf "${pkgdir}${site_packages}/test"
install -Dm644 LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}