summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Loher2017-04-02 08:59:32 +0200
committerJohannes Loher2017-04-02 08:59:32 +0200
commit27d2d52f8625dac14c259a53ce6090e5f51f752f (patch)
tree38cdab3904ca44e68d111fd65b5de5d75e0e047c
downloadaur-27d2d52f8625dac14c259a53ce6090e5f51f752f.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rw-r--r--ansiweather.install11
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8072b975a08e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Apr 2 06:56:27 UTC 2017
+pkgbase = ansiweather
+ pkgdesc = A Shell script for displaying the current weather conditions in your terminal, with support for ANSI colors and Unicode symbols.
+ pkgver = 1.10
+ pkgrel = 1
+ url = https://github.com/fcambus/ansiweather
+ install = ansiweather.install
+ arch = any
+ license = custom
+ depends = curl
+ depends = jq
+ depends = bc
+ optdepends = wget: support for downloading with wget
+ optdepends = ftp: support for downloading with ftp
+ provides = ansiweather
+ source = https://github.com/fcambus/ansiweather/archive/1.10.tar.gz
+ md5sums = 3c52b72f2bfdc94c6f6cd6ecda2d1320
+
+pkgname = ansiweather
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..960a6f00954a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Johannes Loher <johannes dor loher at fg4f dot de>
+
+pkgname='ansiweather'
+pkgver=1.10
+pkgrel=1
+pkgdesc='A Shell script for displaying the current weather conditions in your terminal, with support for ANSI colors and Unicode symbols.'
+arch=('any')
+url='https://github.com/fcambus/ansiweather'
+license=('custom')
+depends=('curl' 'jq' 'bc')
+optdepends=('wget: support for downloading with wget'
+ 'ftp: support for downloading with ftp')
+provides=('ansiweather')
+source=("https://github.com/fcambus/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('3c52b72f2bfdc94c6f6cd6ecda2d1320')
+install=${pkgname}.install
+
+package(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -dm755 "${pkgdir}/usr/bin"
+ install -m755 ${pkgname} "${pkgdir}/usr/bin/"
+
+ install -dm755 "${pkgdir}/usr/share/man/man1"
+ install -m644 ${pkgname}.1 "${pkgdir}/usr/share/man/man1"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/ansiweather.install b/ansiweather.install
new file mode 100644
index 000000000000..6e89e03758bf
--- /dev/null
+++ b/ansiweather.install
@@ -0,0 +1,11 @@
+post_install() {
+ mandb
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}