summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Pento2018-06-04 09:10:57 -0400
committerMike Pento2018-06-04 09:10:57 -0400
commitb19178c832a830704bb743776f220be401e51f54 (patch)
treef47668bd86afa39a5788b110c7e7c4ba3b2afd97
parent5721ef9dd88a080cc93fe237887f1d723d658f0a (diff)
downloadaur-b19178c832a830704bb743776f220be401e51f54.tar.gz
Broke out slim and standard button themes
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fe178d4415e..06487f1a401b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = ant-gtk-theme
pkgdesc = Ant Theme for GTK 3.x
pkgver = 1.1.0
- pkgrel = 5
+ pkgrel = 6
url = https://www.gnome-look.org/p/1099856
arch = any
depends = gtk3
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1525899974/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant.tar
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1526696980/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant-Bloody.tar
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239130/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant-Nebula.tar
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239091/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant-Dracula.tar
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239087/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant-Dracula-slim.tar.xz
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239127/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant-Nebula-slim.tar.xz
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1526696975/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant-Bloody-slim.tar.xz
- source = https://dl.opendesktop.org/api/files/downloadfile/id/1525899970/s/c2f677e01c02c42882c65e832d6d989e/t/1527518010/u/Ant-slim.tar.xz
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1525899974/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant.tar
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1526696980/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant-Bloody.tar
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239130/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant-Nebula.tar
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239091/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant-Dracula.tar
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239087/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant-Dracula-slim.tar.xz
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1525239127/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant-Nebula-slim.tar.xz
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1526696975/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant-Bloody-slim.tar.xz
+ source = https://dl.opendesktop.org/api/files/downloadfile/id/1525899970/s/7797b8dd7420342864a4fac5da490e72/t/1528120268/u/Ant-slim.tar.xz
sha256sums = c7e3b91ec8aae66cfe3de15a4595d3413575b7d7d410ff01f479a89a0af72cbb
sha256sums = 049ad2d833045c746d68770f7182d08ab2e08906b85281c9bbfac0289fc8709b
sha256sums = 0b7d05c11c8f4a50f09dae2555f691e68fede837cd839d735fd750bc3175c57d
diff --git a/PKGBUILD b/PKGBUILD
index 181c9ec7192e..55f3aef54c40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ant-gtk-theme
pkgver=1.1.0
-pkgrel=5
+pkgrel=6
pkgdesc="Ant Theme for GTK 3.x"
arch=(any)
url=https://www.gnome-look.org/p/1099856
@@ -28,7 +28,17 @@ sha256sums=('c7e3b91ec8aae66cfe3de15a4595d3413575b7d7d410ff01f479a89a0af72cbb'
'7d18cefffc6627d14013919d6c4f0c0b52148dbfad920d8f656c33850a90972f'
'3c4f359233e03b2658da380f28a051d25bffaa9f9eb556842f22e2f54f9eba7a')
-package(){
- cd "$srcdir"
- find */ -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
+package() {
+ cd ${srcdir}
+ find Ant{,-Bloody,-Dracula,-Nebula}/ -type f -exec install -Dm644 '{}' "${pkgdir}/usr/share/themes/{}" \;
+
+ # break out '-Slim' and '-standard-buttons' sub-dirs
+ cp -r "${srcdir}/Ant-Slim/Ant-Slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Slim/Ant-Slim-Standard-buttons" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Bloody-Slim/Ant-Bloody-Slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Bloody-Slim/Ant-Bloody-Slim-standard-buttons" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Dracula-Slim/Ant-Dracula-Slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Dracula-Slim/Ant-Dracula-Slim-standard-buttons" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Nebula-Slim/Ant-Nebula-Slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Nebula-Slim/Ant-Nebula-Slim-standard-buttons" "${pkgdir}/usr/share/themes/"
}