summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-12-04 00:18:07 -0500
committerTony Lambiris2018-12-04 00:18:07 -0500
commit537656d82de5f8cf67ded16dc69ac8e8ae6b9e6b (patch)
tree492cb9f2b3011c1ff30a1f01bdc5da0a8244c321
downloadaur-537656d82de5f8cf67ded16dc69ac8e8ae6b9e6b.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD66
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d95dc4f8954e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ant-nebula-theme-git
+ pkgdesc = Nebula variant of the Ant theme
+ pkgver = 54.4e322dc
+ pkgrel = 1
+ url = https://github.com/EliverLara/Ant-Nebula
+ arch = any
+ license = GPL
+ optdepends = ttf-roboto: primary font face defined
+ optdepends = ttf-ubuntu-font-family: secondary font face defined
+ optdepends = cantarell-fonts: tertiary font face defined
+ source = Ant-Nebula::git+https://github.com/EliverLara/Ant-Nebula.git
+ sha256sums = SKIP
+
+pkgname = ant-nebula-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5eaebc980922
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+Ant-Nebula
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18cfaf364415
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=ant-nebula-theme-git
+_pkgname=Ant-Nebula
+pkgver=54.4e322dc
+pkgrel=1
+pkgdesc="Nebula variant of the Ant theme"
+arch=("any")
+url="https://github.com/EliverLara/${_pkgname}"
+license=('GPL')
+optdepends=('ttf-roboto: primary font face defined'
+ 'ttf-ubuntu-font-family: secondary font face defined'
+ 'cantarell-fonts: tertiary font face defined')
+source=("${_pkgname}::git+https://github.com/EliverLara/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ export THEME_FONT_FACE="${THEME_FONT_FACE:-Roboto}"
+ export THEME_FONT_SIZE="${THEME_FONT_SIZE:-10}"
+
+ msg2 "To customize the font size for gnome-shell, build this pacakge"
+ msg2 "with the variables below set to the desired font family and size"
+ msg2 "- THEME_FONT_FACE (default font family is Roboto)"
+ msg2 "- THEME_FONT_SIZE (default font point size is 10)"
+ msg2 ""
+ msg2 "Continuing build in 5 seconds..."; sleep 5
+ msg2 "Setting gnome-shell font face to ${THEME_FONT_FACE}"
+ msg2 "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
+
+ if [ "${THEME_FONT_FACE}" != "Roboto" ]; then
+ sed -i -re "s/font-family: (.*);/font-family: ${THEME_FONT_FACE}, \1;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+
+ if [ "${THEME_FONT_SIZE}" != "10" ]; then
+ sed -i -re "s/font-size: (.*);/font-size: ${THEME_FONT_SIZE}pt;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+
+ msg2 "Rendering assets, please wait"
+ pushd gtk-2.0
+ while read $line; do echo -n "."; done < \
+ <(./render-assets.sh; ); echo
+ popd
+
+ pushd gtk-3.20/assets
+ while read $line; do echo -n "."; done < \
+ <(./render-gtk3-assets.py; ./render-gtk3-assets-hidpi.py); echo
+ popd
+ msg2 "Done!"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/themes/${_pkgname}"
+ cp -a "${srcdir}/${_pkgname}/"* "${pkgdir}/usr/share/themes/${_pkgname}/"
+}