summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Baumann2021-05-14 20:37:22 +0200
committerAndreas Baumann2021-05-14 20:37:22 +0200
commitb8827274a5366b5e31cd0550b3fe32aed6154eb0 (patch)
treef1a2272d9e6111fba52e857620811c4a892cd1fc
parent074de805dc710702fdbf7cdfd62b06f276e2a9f3 (diff)
downloadaur-b8827274a5366b5e31cd0550b3fe32aed6154eb0.tar.gz
added workarounds for FTP and forced HTTPS
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--apache-ant-1.9.15-https-and-repo-urls.patch73
3 files changed, 94 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b29505dd6e7f..c7ff33398340 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,29 @@
pkgbase = ant19
pkgdesc = Java based build tool
pkgver = 1.9.15
- pkgrel = 1
+ pkgrel = 2
url = https://ant.apache.org/
arch = any
license = APACHE
makedepends = bash
- makedepends = java-environment=7
+ makedepends = bin32-jdk6
makedepends = junit
makedepends = java-hamcrest
source = https://www.apache.org/dist/ant/source/apache-ant-1.9.15-src.tar.bz2
source = https://www.apache.org/dist/ant/source/apache-ant-1.9.15-src.tar.bz2.asc
source = ant.conf
+ source = apache-ant-1.9.15-https-and-repo-urls.patch
+ source = NetRexx.zip::ftp://ftp.software.ibm.com/software/awdtools/netrexx/NetRexx.zip
validpgpkeys = CE8075A251547BEE249BC151A2115AE15F6B8B72
validpgpkeys = 8DA70C00DF7AF1B0D2F9DC74DDBCC1270A29D081
sha256sums = 7f7251009dc53e60afac47d0df6bd7e7d3cdba9fa7fec67b7a95412e8becdc8b
sha256sums = SKIP
sha256sums = 23bbef577b56d48adb1985dbd9795e5533146646f1e8bb879dd061a4014ffcf2
+ sha256sums = fc8ed0be9586293a8a7f6cf8d245d1db56c43598b6a155ee27f7a4eeb59cafec
+ sha256sums = 1f99f054e9b1e412d29823088f3fa7cfce90a7af25d907a60a6d7908a6b97ea4
pkgname = ant19
- depends = java-environment=7
+ depends = bin32-jdk6
depends = bash
optdepends = junit: junit tasks
optdepends = java-hamcrest: junit tasks
diff --git a/PKGBUILD b/PKGBUILD
index 44b824640e0b..12468d32c676 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,22 @@ pkgbase=ant19
_pkgbase=ant
pkgname=('ant19' 'ant19-doc')
pkgver=1.9.15
-pkgrel=1
+pkgrel=2
pkgdesc='Java based build tool'
url='https://ant.apache.org/'
arch=('any')
license=('APACHE')
-makedepends=('bash' 'java-environment=7' 'junit' 'java-hamcrest')
+makedepends=('bash' 'bin32-jdk6' 'junit' 'java-hamcrest')
source=(https://www.apache.org/dist/ant/source/apache-${_pkgbase}-${pkgver}-src.tar.bz2{,.asc}
- ant.conf)
+ ant.conf
+ apache-ant-1.9.15-https-and-repo-urls.patch
+ NetRexx.zip::ftp://ftp.software.ibm.com/software/awdtools/netrexx/NetRexx.zip)
+
sha256sums=('7f7251009dc53e60afac47d0df6bd7e7d3cdba9fa7fec67b7a95412e8becdc8b'
'SKIP'
- '23bbef577b56d48adb1985dbd9795e5533146646f1e8bb879dd061a4014ffcf2')
+ '23bbef577b56d48adb1985dbd9795e5533146646f1e8bb879dd061a4014ffcf2'
+ 'fc8ed0be9586293a8a7f6cf8d245d1db56c43598b6a155ee27f7a4eeb59cafec'
+ '1f99f054e9b1e412d29823088f3fa7cfce90a7af25d907a60a6d7908a6b97ea4')
validpgpkeys=(
'CE8075A251547BEE249BC151A2115AE15F6B8B72' # Stefan Bodewig
'8DA70C00DF7AF1B0D2F9DC74DDBCC1270A29D081' # jaikiran@apache <jaikiran@apache.org>
@@ -31,12 +36,15 @@ _replace_lib() {
prepare() {
cd apache-${_pkgbase}-${pkgver}
+ patch -Np1 < $srcdir/apache-ant-1.9.15-https-and-repo-urls.patch
+ mkdir -p ~/.ant/tempcache
+ cp $srcdir/NetRexx.zip ~/.ant/tempcache/.
sed -i 's|/usr/bin/python|/usr/bin/python2|' src/script/runant.py
}
build() {
cd apache-${_pkgbase}-${pkgver}
- export JAVA_HOME=/usr/lib/jvm/default
+ export JAVA_HOME=/usr/lib32/jvm/java-6-jdk
./bootstrap.sh
bootstrap/bin/ant -Ddest=optional -f fetch.xml
_replace_lib /usr/share/java/junit.jar lib/optional/junit-4.12.jar
@@ -46,7 +54,7 @@ build() {
}
package_ant19() {
- depends=('java-environment=7' 'bash')
+ depends=('bin32-jdk6' 'bash')
optdepends=('junit: junit tasks'
'java-hamcrest: junit tasks')
conflicts=('ant')
diff --git a/apache-ant-1.9.15-https-and-repo-urls.patch b/apache-ant-1.9.15-https-and-repo-urls.patch
new file mode 100644
index 000000000000..605b4f7bb833
--- /dev/null
+++ b/apache-ant-1.9.15-https-and-repo-urls.patch
@@ -0,0 +1,73 @@
+diff -rauN apache-ant-1.9.15/fetch.xml apache-ant-1.9.15-https-and-repo-urls-patch/fetch.xml
+--- apache-ant-1.9.15/fetch.xml 2020-05-10 15:42:29.000000000 +0200
++++ apache-ant-1.9.15-https-and-repo-urls-patch/fetch.xml 2021-05-14 20:17:38.020978197 +0200
+@@ -329,19 +329,19 @@
+ <f2 project="tomcat" archive="jasper-runtime"/>
+ <f2 project="javax.servlet" archive="servlet-api"/>
+ </target>
+-
++<!--
+ <target name="jai"
+ description="load Java Advanced Imaging"
+ depends="init">
+ <f2 project="javax.media" archive="jai-core" id="jboss"
+- repository="https://repository.jboss.org/nexus/content/groups/public/"/>
++ repository="http://mvnrepository.com/"/>
+ <f2 project="com.sun.media" archive="jai-codec" id="jboss"
+- repository="https://repository.jboss.org/nexus/content/groups/public/"/>
++ repository="http://repository.jboss.org/nexus/content/groups/public/"/>
+ </target>
+-
++-->
+ <target name="netrexx"
+ description="load NetRexx compiler"
+- depends="init-no-m2,-setup-temp-cache,-fetch-netrexx,-fetch-netrexx-no-commons-net">
++ depends="init-no-m2,-setup-temp-cache">
+ <checksum file="${temp.dir}/NetRexx.zip" algorithm="SHA-256" property="${netrexx.sha256}" verifyProperty="netrexx.hash.matches"/>
+ <fail message="NetRexx.zip fetched via ftp has an unexpected SHA-256 checksum, the file may have been tampered with">
+ <condition>
+@@ -361,18 +361,22 @@
+
+ <available property="have.commons.net" classname="org.apache.commons.net.ftp.FTPClientConfig"/>
+
++<!--
+ <target name="-fetch-netrexx" if="have.commons.net">
+ <get-ftp-file host="ftp.software.ibm.com" remotedir="/software/awdtools/netrexx"
+ filename="NetRexx.zip" localdir="${temp.dir}"/>
+ </target>
++-->
+
++<!--
+ <target name="-fetch-netrexx-no-commons-net" unless="have.commons.net">
+ <get src="ftp://ftp.software.ibm.com/software/awdtools/netrexx/NetRexx.zip"
+ dest="${temp.dir}/NetRexx.zip" skipexisting="true"/>
+ </target>
++-->
+
+ <target name="all"
+ description="load all the libraries (except jython)"
+- depends="antunit,ivy,logging,junit,xml,networking,regexp,antlr,bcel,jdepend,bsf,debugging,script,javamail,jspc,jai,netrexx"/>
++ depends="antunit,ivy,logging,junit,xml,networking,regexp,antlr,bcel,jdepend,bsf,debugging,script,javamail,jspc,netrexx"/>
+
+ </project>
+diff -rauN apache-ant-1.9.15/lib/libraries.properties apache-ant-1.9.15-https-and-repo-urls-patch/lib/libraries.properties
+--- apache-ant-1.9.15/lib/libraries.properties 2020-05-10 15:42:29.000000000 +0200
++++ apache-ant-1.9.15-https-and-repo-urls-patch/lib/libraries.properties 2021-05-14 20:06:47.150502384 +0200
+@@ -17,7 +17,7 @@
+
+ # If you change this, change the checksum to match
+ m2.version=2.1.3
+-m2.url=https://archive.apache.org/dist/maven/ant-tasks
++m2.url=http://archive.apache.org/dist/maven/ant-tasks
+ m2.artifact-name=maven-ant-tasks
+ m2.jar.name=${m2.artifact-name}-${m2.version}.jar
+ #this is the URL of the antlib library, that is pulled down for everything else.
+@@ -26,7 +26,7 @@
+ m2.sha1.checksum=b09be554228d66d208e5fef5266844aacf443abc
+
+ # Repository to use by default for fetching dependencies.
+-m2.repo=https://repo1.maven.org/maven2/
++m2.repo=http://insecure.repo1.maven.org/maven2/
+
+ # hashes of libraries loaded over insecure connections
+ netrexx.sha256=1f99f054e9b1e412d29823088f3fa7cfce90a7af25d907a60a6d7908a6b97ea4